Bug 1811064 - cluster-etcd-operator: peer URL should be IP only
Summary: cluster-etcd-operator: peer URL should be IP only
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1811063
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-06 14:28 UTC by Sam Batschelet
Modified: 2020-05-04 11:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1811063
Environment:
Last Closed: 2020-05-04 11:45:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 239 0 None closed [release-4.4] Bug 1811064: sync with master 03-06 2021-01-05 12:43:15 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:45:29 UTC

Description Sam Batschelet 2020-03-06 14:28:01 UTC
+++ This bug was initially created as a clone of Bug #1811063 +++

Description of problem: To remove the dependency of DNS which can cause connectivity issues. etcd should only use IP vs FQDN for peerURLs.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: etcd uses a mixture of FQDN and IP


Expected results: etcd uses only IPs for peerURL


Additional info:

Comment 3 ge liu 2020-03-09 08:20:54 UTC
No regression issue.

Comment 5 errata-xmlrpc 2020-05-04 11:45:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.