Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1812418 - Monitoring Dashboard: missing unit character in duration
Summary: Monitoring Dashboard: missing unit character in duration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1820672 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 09:58 UTC by Yadan Pei
Modified: 2020-07-13 17:20 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:19:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
Dashboard error (311.55 KB, image/png)
2020-04-04 05:57 UTC, Andrew Pickering
no flags Details
Grafana (no error) (355.37 KB, image/png)
2020-04-04 05:58 UTC, Andrew Pickering
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5152 0 None closed Bug 1812418: Handle the Grafana `$__interval` var 2020-06-23 09:17:24 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:20:06 UTC

Description Yadan Pei 2020-03-11 09:58:30 UTC
Description of problem:
When viewing dashboards at Monitoring -> Dashboards, it reports parse error: missing unit character in duration, query request returns 400 Bad Request

Version-Release number of selected component (if applicable):
    4.5.0-0.ci-2020-03-10-225406

How reproducible:
Always

Steps to Reproduce:
1. cluster admin user visit Monitoring -> Dashboards and view dashboards from dropdown


Actual results:
1. on many pages we can see parse error: missing unit character in duration and GET request returns 400 Bad Requests too, take one as example
https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1583918826.703&end=1583920626.703&step=60&query=%28sum%28irate%28container_network_transmit_packets_dropped_total%7Bcluster%3D%22%22%2C+namespace%3D%7E%22openshift-apiserver%22%7D%5B%24__interval%5D%29%0A*+on+%28namespace%2Cpod%29+%0Agroup_left%28workload%2Cworkload_type%29+mixin_pod_workload%7Bcluster%3D%22%22%2C+namespace%3D%7E%22openshift-apiserver%22%2C+workload%3D%7E%22.%2B%22%2C+workload_type%3D%22deployment%22%7D%29+by+%28workload%29%29%0A&timeout=5s

Expected results:
1. dashboard should be loaded successfully without error

Additional info:

Comment 1 Andrew Pickering 2020-04-04 05:53:39 UTC
*** Bug 1820672 has been marked as a duplicate of this bug. ***

Comment 2 Andrew Pickering 2020-04-04 05:57:13 UTC
Created attachment 1676174 [details]
Dashboard error

Comment 3 Andrew Pickering 2020-04-04 05:58:04 UTC
Created attachment 1676175 [details]
Grafana (no error)

Comment 4 Andrew Pickering 2020-04-21 01:45:01 UTC
This error is on the admin perspective monitoring dashboard.

Comment 5 Samuel Padgett 2020-04-22 17:13:22 UTC
We're not handling the `$__interval` variable:

https://grafana.com/docs/grafana/latest/reference/templating/#the-interval-variable

Comment 9 XiaochuanWang 2020-04-27 05:39:16 UTC
Dashboards does not display any error now. 
Verified on 4.5.0-0.nightly-2020-04-26-203839

Comment 11 errata-xmlrpc 2020-07-13 17:19:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.