Bug 1812718 - cluster-etcd-operator: excessive cpu usage while idle.
Summary: cluster-etcd-operator: excessive cpu usage while idle.
Keywords:
Status: CLOSED DUPLICATE of bug 1832901
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Dan Mace
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 23:16 UTC by Sam Batschelet
Modified: 2020-05-21 18:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-21 18:07:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sam Batschelet 2020-03-11 23:16:11 UTC
Description of problem:

the etcd operator is using a fair amount of CPU at idle - ~130m.  It should probably not take that much (since it is merely observing state) - can someone take a look at why it is consuming 2x what OLM takes and 10x what the CVO uses?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: reasonable CPU usage.


Additional info:

Comment 4 Sam Batschelet 2020-05-21 18:07:23 UTC
May 2nd we see CPU about.125- .130m as reported for AWS e2e CI


After https://bugzilla.redhat.com/show_bug.cgi?id=1832901 landed this reduced this to .051 so that is over 90% reduction. We will continue to try and improve but I believe the initial concern has been addressed as .130 was very excessive.

*** This bug has been marked as a duplicate of bug 1832901 ***

Comment 5 Sam Batschelet 2020-05-21 18:08:32 UTC
Clarification, the above numbers were during CI run idle is about .029m


Note You need to log in before you can comment on or make changes to this bug.