Bug 1832901 - etcd-operator spuriously reconciles in response to global configmap watch events
Summary: etcd-operator spuriously reconciles in response to global configmap watch events
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
: 1812718 (view as bug list)
Depends On:
Blocks: 1832919
TreeView+ depends on / blocked
 
Reported: 2020-05-07 12:59 UTC by Dan Mace
Modified: 2020-07-13 17:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1832919 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:35:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 332 0 None closed Bug 1832901: Stop reconciling in response to global configmap events 2020-06-24 02:05:47 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:36:12 UTC

Description Dan Mace 2020-05-07 12:59:16 UTC
Description of problem:

The etcd-operator is unnecessarily triggering reconciliation in response to any configmap watch event across all namespaces. Given the volume and churn of configmaps in any nontrivial production cluster, combined with the actions performed during a reconciliation (which at present include active etcd API calls to list members and their status), the resulting chatter with etcd seems excessive (although I haven't yet performed systematic measurements).


Version-Release number of selected component (if applicable):

4.4, 4.5

How reproducible:

Launch a new cluster IPI cluster on any platform.

Actual results:

The etcd-operator reconciles once for every configmap in the system, and then in response to any change to any configmap in the system after the initial sync.

Expected results:

The etcd-operator should only reconcile when relevant changes (e.g. node churn) occur.

Additional info:

Comment 3 ge liu 2020-05-20 07:26:22 UTC
Tried with 4.5.0-0.nightly-2020-05-19-041951, the map trend looks like well, pls comments if any misunderstanding.

Comment 5 Sam Batschelet 2020-05-21 18:07:23 UTC
*** Bug 1812718 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2020-07-13 17:35:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.