Bug 181289 - openssl-devel.i386 missing from x86-64 distribution
Summary: openssl-devel.i386 missing from x86-64 distribution
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: comps   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
: 181291 (view as bug list)
Depends On:
Blocks: FC6Blocker
TreeView+ depends on / blocked
 
Reported: 2006-02-12 21:56 UTC by H. Peter Anvin
Modified: 2013-01-10 01:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 20:58:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description H. Peter Anvin 2006-02-12 21:56:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
openssl-devel.i386 is missing from the x86-64 distribution.  It makes it impossible to build 32-bit applications which require any of the openssl libraries on a 64-bit machine.

Installed from a 32-bit distribution it works fine, so it only needs to be added to the 64-bit distribution (so updating works.)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to build an openssl-using application, e.g. git, as a 32-bit application on an x86-64 system


Additional info:

Comment 1 H. Peter Anvin 2006-02-13 03:41:34 UTC
*** Bug 181291 has been marked as a duplicate of this bug. ***

Comment 2 Tomas Mraz 2006-02-13 07:44:34 UTC
Reassigned.

Comment 3 Rahul Sundaram 2006-02-20 11:07:52 UTC

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Comment 4 Tomas Mraz 2006-02-20 11:43:24 UTC
This bug is definitely not fixed yet.

Comment 5 Warren Togami 2006-03-06 15:51:08 UTC
Is it really clear that we want this?  It is trivially easy to create a chroot
with an easy automated tool like mock to build 32bit binaries for use elsewhere.

Comment 6 Warren Togami 2006-03-06 15:53:47 UTC
Even if this is desirable, openssl headers are not arch clean, so this would
cause conflicts if we did it now.  Moving to FC6 for now.


Comment 7 Tomas Mraz 2006-03-06 16:03:28 UTC
They actually are arch clean.


Comment 8 Warren Togami 2006-03-06 16:09:20 UTC
OK, but we have no time left to do this in FC5.  We have too many other last
minute changes to make of higher priority.


Comment 9 Jesse Keating 2006-04-19 20:16:12 UTC
This requires some core changes to how multi-lib is figured out and evaulated. 
Deferring until such time.

Comment 10 Trond Eivind Glomsrød 2006-04-26 10:43:48 UTC
This is a problem for RHEL4 as well....

Comment 11 Jesse Keating 2006-06-21 20:58:19 UTC
This has been fixed in FC6 Test1.


Note You need to log in before you can comment on or make changes to this bug.