Bug 1812920 - No nodeSelector=kubernetes.io/os: linux in CLO and EO
Summary: No nodeSelector=kubernetes.io/os: linux in CLO and EO
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On: 1808986
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-12 14:11 UTC by Jeff Cantrill
Modified: 2020-05-04 11:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1808986
Environment:
Last Closed: 2020-05-04 11:45:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-logging-operator pull 409 0 None closed Bug 1812920: Adding nodeSelector to operator deployment 2020-07-01 12:36:16 UTC
Github openshift elasticsearch-operator pull 263 0 None closed Bug 1812920: Adding nodeSelector to operator deployment 2020-07-01 12:36:15 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:46:15 UTC

Description Jeff Cantrill 2020-03-12 14:11:52 UTC
+++ This bug was initially created as a clone of Bug #1808986 +++

Description of problem:
No nodeSelector=kubernetes.io/os: linux  for ClusterLogging Operator and Elasticsearch Operator.

Version-Release number of selected component (if applicable):
elasticsearch-operator.4.4.0-202003011731
clusterlogging.4.4.0-202003011731

How reproducible:
always

Steps to Reproduce:
1. oc get deployment elasticsearch-operator -o json |jq '.spec.template.spec.nodeSelector'
null

2.  oc get deployment cluster-logging-operator -o json |jq '.spec.template.spec.nodeSelector'
null

Actual results:
No nodeSelector kubernetes.io/os: linux

Expected results:
nodeSelector: 
{
  "kubernetes.io/os": "linux"
}



Additional info:

Comment 3 Anping Li 2020-04-06 13:59:59 UTC
Verified on CSV 4.4.0-202004040654

Comment 5 errata-xmlrpc 2020-05-04 11:45:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.