Bug 18130 - RFE: kickstart: interactive network configuration if requested
RFE: kickstart: interactive network configuration if requested
Status: CLOSED DUPLICATE of bug 17826
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-02 15:55 EDT by Pekka Savola
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 16:23:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-10-02 15:55:54 EDT
I've tested this in Red Hat Linux 6.2, but I don't see any reason why this would be 
different on RH7.0, so...

In kickstart configuration, if you define networking with 'network' + options, it 
will be set up.  If that information is omitted, network won't be configured at all.

Would it be possible to code an option like:

network --prompt

which would ask interactively for the networking to be set up.  It could be either:

1) Done first so that networked install would use these and kickstart with bootnet 
without ks.cfg modifications or DHCP would be possible, or

2) Done later; this would only help for HDD/CD installs.

Note: I've noticed that running netconfig after the install will usually cause 
different network configuration -- and with kickstarts, running it might not always be
possible.
Comment 1 Michael Fulbright 2000-10-03 16:23:08 EDT

*** This bug has been marked as a duplicate of 17826 ***

Note You need to log in before you can comment on or make changes to this bug.