Bug 1813175 - Still alert for SamplesInvalidConfig and SamplesMissingSecret events when samples operator set to removed during bootstrap
Summary: Still alert for SamplesInvalidConfig and SamplesMissingSecret events when sam...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.5.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks: 1814395
TreeView+ depends on / blocked
 
Reported: 2020-03-13 07:15 UTC by XiuJuan Wang
Modified: 2020-08-04 18:05 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: samples operator would still send alerts about invalid configuration or missing image pull secrets when it was boostrapped as removed, meaning valid config or pull secrets are not required or set up Consequence: misleading and confusing alerts are provided to users Fix: samples operator was updated to not fire alerts related to importing samples when it was bootstrapped as removed Result: these confusing / misleading alerts when samples operator is removed are no longer sent
Clone Of:
: 1814395 1814396 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:05:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
alert of samples operator (82.32 KB, image/jpeg)
2020-03-13 07:35 UTC, XiuJuan Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 246 None closed Bug 1813175: abort metrics in general if removed/unmanaged 2020-06-23 09:23:27 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:05:32 UTC

Description XiuJuan Wang 2020-03-13 07:15:04 UTC
Description of problem:
In ipv6 and disconnect installation, samples operator set to Removed during the bootstrap state. But still alert for SamplesInvalidConfig and SamplesMissingSecret events.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-03-12-052849

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:

There is no 
$ oc describe config.samples cluster 
Name:         cluster
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  samples.operator.openshift.io/v1
Kind:         Config
Metadata:
  Creation Timestamp:  2020-03-13T04:18:10Z
  Finalizers:
    samples.operator.openshift.io/finalizer
  Generation:        1
  Resource Version:  17054
  Self Link:         /apis/samples.operator.openshift.io/v1/configs/cluster
  UID:               af601c7e-2508-486f-a5f4-0e921a01f5d7
Spec:
  Architectures:
    x86_64
  Management State:  Removed
Status:
  Conditions:
    Last Transition Time:  2020-03-13T04:18:16Z
    Last Update Time:      2020-03-13T04:18:16Z
    Status:                False
    Type:                  RemovePending
    Last Transition Time:  2020-03-13T04:18:13Z
    Last Update Time:      2020-03-13T04:18:13Z
    Status:                False
    Type:                  SamplesExist
    Last Transition Time:  2020-03-13T04:18:13Z
    Last Update Time:      2020-03-13T04:18:13Z
    Status:                False
    Type:                  ImageChangesInProgress
    Last Transition Time:  2020-03-13T04:18:13Z
    Last Update Time:      2020-03-13T04:18:13Z
    Status:                False
    Type:                  ImportImageErrorsExist
  Management State:        Removed
  Version:                 4.4.0-0.nightly-2020-03-12-052849
Events:                    <none>

$ oc describe co  openshift-samples  
Name:         openshift-samples
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2020-03-13T04:18:10Z
  Generation:          1
  Resource Version:    17017
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/openshift-samples
  UID:                 ea0e8b22-a0ad-4e1a-a031-3e33b34f3349
Spec:
Status:
  Conditions:
    Last Transition Time:  2020-03-13T04:18:10Z
    Reason:                TermsBasedRegistryUnreacahable
    Status:                False
    Type:                  Progressing
    Last Transition Time:  2020-03-13T04:18:10Z
    Reason:                TermsBasedRegistryUnreacahable
    Status:                False
    Type:                  Degraded
    Last Transition Time:  2020-03-13T04:18:16Z
    Reason:                TermsBasedRegistryUnreacahable
    Status:                True
    Type:                  Available
  Extension:               <nil>
  Related Objects:
    Group:     samples.operator.openshift.io
    Name:      cluster
    Resource:  configs
    Group:     
    Name:      openshift-cluster-samples-operator
    Resource:  namespaces
    Group:     
    Name:      openshift
    Resource:  namespaces
  Versions:
    Name:     operator
    Version:  4.4.0-0.nightly-2020-03-12-052849
Events:       <none>

Expected results:
Should not alert for that events.

Additional info:
The managed status
 oc describe config.samples  
Name:         cluster
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  samples.operator.openshift.io/v1
Kind:         Config
Metadata:
  Creation Timestamp:  2020-03-12T02:47:28Z
  Finalizers:
    samples.operator.openshift.io/finalizer
  Generation:        1
  Resource Version:  13641
  Self Link:         /apis/samples.operator.openshift.io/v1/configs/cluster
  UID:               9b1bed13-a870-4936-94e3-96736bb83f4d
Spec:
  Architectures:
    x86_64
  Management State:  Managed
Status:
  Architectures:
    x86_64
  Conditions:
    Last Transition Time:  2020-03-12T02:47:28Z
    Last Update Time:      2020-03-12T02:47:28Z
    Status:                True
    Type:                  ImportCredentialsExist
    Last Transition Time:  2020-03-12T02:47:33Z
    Last Update Time:      2020-03-12T02:47:33Z
    Status:                True
    Type:                  ConfigurationValid
    Last Transition Time:  2020-03-12T02:47:28Z
    Last Update Time:      2020-03-12T02:47:31Z
    Status:                False
    Type:                  ImportImageErrorsExist
    Last Transition Time:  2020-03-12T02:47:39Z
    Last Update Time:      2020-03-12T02:47:39Z
    Status:                False
    Type:                  ImageChangesInProgress
    Last Transition Time:  2020-03-12T02:47:36Z
    Last Update Time:      2020-03-12T02:47:36Z
    Status:                True
    Type:                  SamplesExist
    Last Transition Time:  2020-03-12T02:47:33Z
    Last Update Time:      2020-03-12T02:47:33Z
    Status:                False
    Type:                  RemovePending
    Last Transition Time:  2020-03-12T02:47:33Z
    Last Update Time:      2020-03-12T02:47:33Z
    Status:                False
    Type:                  MigrationInProgress
  Management State:        Managed
  Version:                 4.4.0-0.nightly-2020-03-11-212258

Comment 1 XiuJuan Wang 2020-03-13 07:35:35 UTC
Created attachment 1669861 [details]
alert of samples operator

Comment 4 Gabe Montero 2020-03-18 13:05:35 UTC
fyi @XiuJuan given the priority/severity here and low PM scores, I'm going to close the 4.3.z and 4.4.z clones of this.

But I'll give you a chance to chime in before I do so.

Comment 6 XiuJuan Wang 2020-03-19 08:13:04 UTC
Verified with 4.5.0-0.nightly-2020-03-18-115438 cluster.
Abort metrics when samples operator is set to Unmanaged/Removed state.

Comment 9 errata-xmlrpc 2020-08-04 18:05:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.