Bug 1814395 - Still alert for SamplesInvalidConfig and SamplesMissingSecret events when samples operator set to removed during bootstrap
Summary: Still alert for SamplesInvalidConfig and SamplesMissingSecret events when sam...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.4.z
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On: 1813175
Blocks: 1814396
TreeView+ depends on / blocked
 
Reported: 2020-03-17 18:52 UTC by Gabe Montero
Modified: 2020-05-26 16:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: samples operator would still send alerts about invalid configuration or missing image pull secrets when it was boostrapped as removed, meaning valid config or pull secrets are not required or set up Consequence: misleading and confusing alerts are provided to users Fix: samples operator was updated to not fire alerts related to importing samples when it was bootstrapped as removed Result: these confusing / misleading alerts when samples operator is removed are no longer sent
Clone Of: 1813175
Environment:
Last Closed: 2020-05-26 16:50:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 250 None closed [release-4.4] Bug 1814395: abort metrics in general if removed/unmanaged 2020-06-18 13:30:34 UTC
Red Hat Product Errata RHBA-2020:2180 None None None 2020-05-26 16:50:53 UTC

Description Gabe Montero 2020-03-17 18:52:47 UTC
+++ This bug was initially created as a clone of Bug #1813175 +++

Description of problem:
In ipv6 and disconnect installation, samples operator set to Removed during the bootstrap state. But still alert for SamplesInvalidConfig and SamplesMissingSecret events.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-03-12-052849

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:

There is no 
$ oc describe config.samples cluster 
Name:         cluster
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  samples.operator.openshift.io/v1
Kind:         Config
Metadata:
  Creation Timestamp:  2020-03-13T04:18:10Z
  Finalizers:
    samples.operator.openshift.io/finalizer
  Generation:        1
  Resource Version:  17054
  Self Link:         /apis/samples.operator.openshift.io/v1/configs/cluster
  UID:               af601c7e-2508-486f-a5f4-0e921a01f5d7
Spec:
  Architectures:
    x86_64
  Management State:  Removed
Status:
  Conditions:
    Last Transition Time:  2020-03-13T04:18:16Z
    Last Update Time:      2020-03-13T04:18:16Z
    Status:                False
    Type:                  RemovePending
    Last Transition Time:  2020-03-13T04:18:13Z
    Last Update Time:      2020-03-13T04:18:13Z
    Status:                False
    Type:                  SamplesExist
    Last Transition Time:  2020-03-13T04:18:13Z
    Last Update Time:      2020-03-13T04:18:13Z
    Status:                False
    Type:                  ImageChangesInProgress
    Last Transition Time:  2020-03-13T04:18:13Z
    Last Update Time:      2020-03-13T04:18:13Z
    Status:                False
    Type:                  ImportImageErrorsExist
  Management State:        Removed
  Version:                 4.4.0-0.nightly-2020-03-12-052849
Events:                    <none>

$ oc describe co  openshift-samples  
Name:         openshift-samples
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2020-03-13T04:18:10Z
  Generation:          1
  Resource Version:    17017
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/openshift-samples
  UID:                 ea0e8b22-a0ad-4e1a-a031-3e33b34f3349
Spec:
Status:
  Conditions:
    Last Transition Time:  2020-03-13T04:18:10Z
    Reason:                TermsBasedRegistryUnreacahable
    Status:                False
    Type:                  Progressing
    Last Transition Time:  2020-03-13T04:18:10Z
    Reason:                TermsBasedRegistryUnreacahable
    Status:                False
    Type:                  Degraded
    Last Transition Time:  2020-03-13T04:18:16Z
    Reason:                TermsBasedRegistryUnreacahable
    Status:                True
    Type:                  Available
  Extension:               <nil>
  Related Objects:
    Group:     samples.operator.openshift.io
    Name:      cluster
    Resource:  configs
    Group:     
    Name:      openshift-cluster-samples-operator
    Resource:  namespaces
    Group:     
    Name:      openshift
    Resource:  namespaces
  Versions:
    Name:     operator
    Version:  4.4.0-0.nightly-2020-03-12-052849
Events:       <none>

Expected results:
Should not alert for that events.

Additional info:
The managed status
 oc describe config.samples  
Name:         cluster
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  samples.operator.openshift.io/v1
Kind:         Config
Metadata:
  Creation Timestamp:  2020-03-12T02:47:28Z
  Finalizers:
    samples.operator.openshift.io/finalizer
  Generation:        1
  Resource Version:  13641
  Self Link:         /apis/samples.operator.openshift.io/v1/configs/cluster
  UID:               9b1bed13-a870-4936-94e3-96736bb83f4d
Spec:
  Architectures:
    x86_64
  Management State:  Managed
Status:
  Architectures:
    x86_64
  Conditions:
    Last Transition Time:  2020-03-12T02:47:28Z
    Last Update Time:      2020-03-12T02:47:28Z
    Status:                True
    Type:                  ImportCredentialsExist
    Last Transition Time:  2020-03-12T02:47:33Z
    Last Update Time:      2020-03-12T02:47:33Z
    Status:                True
    Type:                  ConfigurationValid
    Last Transition Time:  2020-03-12T02:47:28Z
    Last Update Time:      2020-03-12T02:47:31Z
    Status:                False
    Type:                  ImportImageErrorsExist
    Last Transition Time:  2020-03-12T02:47:39Z
    Last Update Time:      2020-03-12T02:47:39Z
    Status:                False
    Type:                  ImageChangesInProgress
    Last Transition Time:  2020-03-12T02:47:36Z
    Last Update Time:      2020-03-12T02:47:36Z
    Status:                True
    Type:                  SamplesExist
    Last Transition Time:  2020-03-12T02:47:33Z
    Last Update Time:      2020-03-12T02:47:33Z
    Status:                False
    Type:                  RemovePending
    Last Transition Time:  2020-03-12T02:47:33Z
    Last Update Time:      2020-03-12T02:47:33Z
    Status:                False
    Type:                  MigrationInProgress
  Management State:        Managed
  Version:                 4.4.0-0.nightly-2020-03-11-212258

--- Additional comment from XiuJuan Wang on 2020-03-13 07:35:35 UTC ---

Comment 1 Gabe Montero 2020-03-19 15:14:45 UTC
PR https://github.com/openshift/cluster-samples-operator/pull/250 is up but we are getting bugzilla bot hoopla wrt 4.4.0 vs. 4.4.z

Comment 2 Gabe Montero 2020-04-13 21:15:23 UTC
per discussion with Adam, setting target for 4.4.0

will let patch managers make final call on inclusion

Comment 8 XiuJuan Wang 2020-05-18 11:08:31 UTC
Verified this bug with 4.4.0-0.nightly-2020-05-18-014003.

Comment 10 errata-xmlrpc 2020-05-26 16:50:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2180


Note You need to log in before you can comment on or make changes to this bug.