SSO (single sign-on) is being reconfigured. Maintenance started Jul 16 2:20PM UTC and will last 1 hour. Password-enabled login should still work.
Bug 1813297 - Downloads Page: Some of the oc downloads should be marked "unsupported".
Summary: Downloads Page: Some of the oc downloads should be marked "unsupported".
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1813296
Blocks: 1813302
TreeView+ depends on / blocked
 
Reported: 2020-03-13 13:42 UTC by bpeterse
Modified: 2020-05-04 11:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1813296
: 1813302 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:46:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 394 None closed [release-4.4] Bug 1813297: Update oc clidownload cr to indicate that certain builds are unsupported 2020-04-14 10:04:32 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:46:48 UTC

Description bpeterse 2020-03-13 13:42:18 UTC
+++ This bug was initially created as a clone of Bug #1813296 +++

Description of problem:

There are currently 6 oc downloads listed:

Download oc for Linux for x86_64
Download oc for Linux for ARM 64 
Download oc for Linux for IBM Power, little endian 
Download oc for Linux for IBM Z 
Download oc for Mac for x86_64
Download oc for Windows for x86_64


However, 3 of them should be listed as unsupported:


Download oc for Linux for x86_64
Download oc for Mac for x86_64
Download oc for Windows for x86_64
Download oc for Linux for ARM 64 (unsupported)
Download oc for Linux for IBM Power, little endian (unsupported)
Download oc for Linux for IBM Z (unsupported)


How reproducible:

Always

Steps to Reproduce:
1. Visit the CLI Downloads page

Actual results:

There are 6 items, all appear supported.

Expected results:

ARM & IBM builds are not yet supported.

Additional info:

When we are ready to fully support these builds, we will remove the unsupported label.

Comment 3 Yadan Pei 2020-04-03 06:03:42 UTC
fix is not included in 4.4.0-0.nightly-2020-04-02-130551 yet

Comment 4 XiaochuanWang 2020-04-07 02:26:33 UTC
Verified on 4.4.0-0.nightly-2020-04-04-025830

Now they are listed as:
    Download oc for Linux for x86_64
    Download oc for Mac for x86_64
    Download oc for Windows for x86_64
    Download oc for Linux for ARM 64 (unsupported)
    Download oc for Linux for IBM Power, little endian (unsupported)
    Download oc for Linux for IBM Z (unsupported)

Comment 6 errata-xmlrpc 2020-05-04 11:46:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.