Bug 1813302 - Downloads Page: Some of the oc downloads should be marked "unsupported".
Summary: Downloads Page: Some of the oc downloads should be marked "unsupported".
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.z
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1813297
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-13 13:53 UTC by bpeterse
Modified: 2020-04-30 01:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1813297
Environment:
Last Closed: 2020-04-30 01:28:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 409 None closed [release-4.3] Bug 1813302: Update oc clidownload cr to indicate that certain builds are unsupported 2020-04-29 12:40:43 UTC
Red Hat Product Errata RHBA-2020:1529 None None None 2020-04-30 01:28:21 UTC

Description bpeterse 2020-03-13 13:53:01 UTC
+++ This bug was initially created as a clone of Bug #1813297 +++

+++ This bug was initially created as a clone of Bug #1813296 +++

Description of problem:

There are currently 6 oc downloads listed:

Download oc for Linux for x86_64
Download oc for Linux for ARM 64 
Download oc for Linux for IBM Power, little endian 
Download oc for Linux for IBM Z 
Download oc for Mac for x86_64
Download oc for Windows for x86_64


However, 3 of them should be listed as unsupported:


Download oc for Linux for x86_64
Download oc for Mac for x86_64
Download oc for Windows for x86_64
Download oc for Linux for ARM 64 (unsupported)
Download oc for Linux for IBM Power, little endian (unsupported)
Download oc for Linux for IBM Z (unsupported)


How reproducible:

Always

Steps to Reproduce:
1. Visit the CLI Downloads page

Actual results:

There are 6 items, all appear supported.

Expected results:

ARM & IBM builds are not yet supported.

Additional info:

When we are ready to fully support these builds, we will remove the unsupported label.

Comment 4 shahan 2020-04-20 02:34:26 UTC
Goto help->commannd lines tools page , there are unsupported keyword for those items.
4.3.0-0.nightly-2020-04-18-075046

Comment 6 errata-xmlrpc 2020-04-30 01:28:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1529


Note You need to log in before you can comment on or make changes to this bug.