Bug 181366 - Intel PRO 1000 nic not working with kernel-2.6.15-1.1831_FC4
Intel PRO 1000 nic not working with kernel-2.6.15-1.1831_FC4
Status: CLOSED DUPLICATE of bug 181368
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 13:30 EST by Travis Shugarts
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 13:46:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Travis Shugarts 2006-02-13 13:30:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
I have an Intel D945PSN main board with an integrated PRO 1000 gigabit Ethernet adaptor. After updating the system to kernel-2.6.15-1.1831_FC4 from kernel-2.6.14-1.1656_FC4 the onboard nic ceases to function properly.

Attempting to ping or telnet to another host results in a network unreachable error.  I observe a large number (50%) of receive overrun and frame errors on the interface with the new kernel. I thought there might have been a problem with the auto-configuration of the nic so I set the interface to 10Mb/s-HD which caused the frame errors to stop, but the problem still persisted.

I noticed in the system log many of the following messages:

Feb 11 11:14:21 atlas kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Down
Feb 11 11:14:25 atlas kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Up 100 Mbps Full Duplex

After rebooting back to the 2.6.14 kernel the ethernet adaptor operates normally so I think it’s safe to assume the problem is with the 2.6.15 kernel and the e1000 driver.


Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1831_FC4

How reproducible:
Always

Steps to Reproduce:
1.reboot system into kernel-2.6.15-1.1831_FC4 or kernel-2.6.15-1.1830_FC4
2.
3.
  

Additional info:
Comment 1 Travis Shugarts 2006-02-13 13:46:18 EST

*** This bug has been marked as a duplicate of 181368 ***

Note You need to log in before you can comment on or make changes to this bug.