Bug 1813707 - Pipeline Builder - Handle Array Parameters
Summary: Pipeline Builder - Handle Array Parameters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1813884
TreeView+ depends on / blocked
 
Reported: 2020-03-15 16:21 UTC by Andrew Ballantyne
Modified: 2020-07-13 17:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The Pipeline Builder reads Task/ClusterTask definitions and made an incorrect assumption that all Parameters were of type string. Consequence: When a Task Param of type array was encountered, it would cast the array to a string and represent it losing the type and would produce a value to the Task param as string thus breaking the contract with the Task. Fix: Support Array type in the UI and properly retrain the type Result: Managing both types allows the Pipeline Builder to work the way it was intended.
Clone Of:
: 1813884 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:20:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
parameters send to the pipeline (105.56 KB, image/png)
2020-03-17 12:41 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4735 None closed Bug 1813707: Fix Pipeline Builder paramters of type Array 2020-06-30 18:53:25 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:20:31 UTC

Description Andrew Ballantyne 2020-03-15 16:21:16 UTC
Description of problem:
While using the Pipeline Builder, when a parameter of type array is used, it doesn't come out of the builder as type array... but instead of type string. This is a type violation and thus prevents the Pipeline from being started.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create using the Pipeline Builder (create button on the Pipelines list view)
2. Add `openshift-client`
3. See a text input, update, and create Pipeline

Actual results:
The value was saved as a string in the YAML; Pipeline won't start.

Expected results:
The value should be saved as an array.

Additional info:

Comment 3 Gajanan More 2020-03-17 12:41:00 UTC
Created attachment 1670789 [details]
parameters send to the pipeline

Comment 4 Gajanan More 2020-03-17 12:43:24 UTC
I have validated the bug on 
Build: 4.5.0-0.nightly-2020-03-16-234954
Browser: Google Chrome Version 78.0.3904.108
Marking this as verified.

Comment 6 errata-xmlrpc 2020-07-13 17:20:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.