Bug 1813884 - Pipeline Builder - Handle Array Parameters
Summary: Pipeline Builder - Handle Array Parameters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.4.z
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1813707
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-16 12:04 UTC by Andrew Ballantyne
Modified: 2020-06-02 11:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1813707
Environment:
Last Closed: 2020-06-02 11:17:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Pipeline Builder - Handle Array Parameters (89.66 KB, image/png)
2020-05-26 12:16 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4738 None closed Bug 1813884: Fix Pipeline Builder parameters of type Array 2020-06-18 14:19:20 UTC
Red Hat Product Errata RHBA-2020:2310 None None None 2020-06-02 11:18:14 UTC

Description Andrew Ballantyne 2020-03-16 12:04:57 UTC
+++ This bug was initially created as a clone of Bug #1813707 +++

Description of problem:
While using the Pipeline Builder, when a parameter of type array is used, it doesn't come out of the builder as type array... but instead of type string. This is a type violation and thus prevents the Pipeline from being started.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create using the Pipeline Builder (create button on the Pipelines list view)
2. Add `openshift-client`
3. See a text input, update, and create Pipeline

Actual results:
The value was saved as a string in the YAML; Pipeline won't start.

Expected results:
The value should be saved as an array.

Additional info:

Comment 1 Andrew Ballantyne 2020-03-16 12:39:24 UTC
Assigning to me as we wait for 4.4.z-stream to open up.

Comment 4 spathak@redhat.com 2020-05-26 12:16:58 UTC
Created attachment 1692242 [details]
Pipeline Builder - Handle Array Parameters

Comment 5 spathak@redhat.com 2020-05-26 12:33:19 UTC
Validated on build version:4.4.0-0.ci-2020-05-25-181336
Browser version: Chrome 81

Comment 7 errata-xmlrpc 2020-06-02 11:17:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310


Note You need to log in before you can comment on or make changes to this bug.