Bug 181465 - (multipleSUP) Object class SUP declaration (not RFC compliant)
Object class SUP declaration (not RFC compliant)
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Schema (Show other bugs)
1.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
: 181466 (view as bug list)
Depends On:
Blocks: 434914 389_1.2.1
  Show dependency treegraph
 
Reported: 2006-02-14 09:11 EST by Yacine Kheddache
Modified: 2015-12-07 12:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:17:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (2.29 KB, patch)
2009-05-29 17:31 EDT, Nathan Kinder
no flags Details | Diff

  None (edit)
Description Yacine Kheddache 2006-02-14 09:11:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
Hi,

When playing with openldap schema conversion to FDS I discover this issue below:

RFC 2252 say for object class:
[ "SUP" oids ]
 
Where :
oids            = woid / ( "(" oidlist ")" )
oidlist         = woid *( "$" woid )

One of my converted schema contains this line;
SUP (inetOrgPerson $ PureFTPdUser )

And based on RFC 2252 it is RFC compliant.

But FDS complain with error below:
error code 20 (Type or value exists) - object class ispmanDomainUser: Superior object class "(inetOrgPerson" does not exist

Line (workaround):
SUP inetOrgPerson $ PureFTPdUser
is working without any FDS complains. 

So I guess FDS is not RFC compliant on this point.

Regards
Yacine (Yada on  #fedora-ds)


Version-Release number of selected component (if applicable):
FDS 1.0.1

How reproducible:
Always

Steps to Reproduce:
1. use parenthesis in a schema for an object class SUP declaration
2. restart FDS
3.
  

Actual Results:  error code 20 (Type or value exists) - object class "foo": Superior object class "(bar" does not exist


Expected Results:  Should restart without errors and take the SUP () declaration into account.

Additional info:
Comment 1 Rich Megginson 2006-02-14 09:15:55 EST
*** Bug 181466 has been marked as a duplicate of this bug. ***
Comment 2 Pete Rowley 2006-02-14 14:05:05 EST
I believe the current parser is space sensitive (and really should not be) - it
requires a space between the bracket and the list item.
Comment 3 Yacine Kheddache 2006-02-14 17:58:03 EST
Correct it work fine with:
SUP ( inetOrgPerson $ PureFTPdUser )
Comment 7 Rich Megginson 2009-04-09 12:51:08 EDT
This falls under the category of "improve schema parsing" and "RFC correctness"
Comment 8 Nathan Kinder 2009-05-29 17:31:34 EDT
Created attachment 345962 [details]
Patch

Our schema parser requires a space after the opening paran
when multiple SUP objectclasses are listed in the definition
of an objectclass.  The RFCs show that a space is not required.
    
This patch simply removes the requirement that a space be
present after the opening paran.
Comment 9 Nathan Kinder 2009-05-29 17:34:27 EDT
Pushed patch to master.
Comment 10 Jenny Galipeau 2010-06-07 11:26:58 EDT
verified RHEL 4

version:
redhat-ds-base-8.2.0-2010060704.el4dsrv

Successfully added the following schema without spaces between the brackets

dn: cn=schema
changetype: modify
add: objectclasses
objectclasses: (1.22.333.4444 NAME 'myMozOC' DESC 'Objectclass that contains MozillaAttribute' SUP top STRUCTURAL MUST (cn $ MozillaAttribute))

Note You need to log in before you can comment on or make changes to this bug.