Bug 181466 - Object class SUP declaration (not RFC compliant)
Summary: Object class SUP declaration (not RFC compliant)
Status: CLOSED DUPLICATE of bug 181465
Alias: None
Product: 389
Classification: Retired
Component: Directory Server (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Orla Hegarty
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-14 14:11 UTC by Yacine Kheddache
Modified: 2008-08-11 23:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 14:15:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yacine Kheddache 2006-02-14 14:11:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
Hi,

When playing with openldap schema conversion to FDS I discover this issue below:

RFC 2252 say for object class:
[ "SUP" oids ]
 
Where :
oids            = woid / ( "(" oidlist ")" )
oidlist         = woid *( "$" woid )

One of my converted schema contains this line;
SUP (inetOrgPerson $ PureFTPdUser )

And based on RFC 2252 it is RFC compliant.

But FDS complain with error below:
error code 20 (Type or value exists) - object class ispmanDomainUser: Superior object class "(inetOrgPerson" does not exist

Line (workaround):
SUP inetOrgPerson $ PureFTPdUser
is working without any FDS complains. 

So I guess FDS is not RFC compliant on this point.

Regards
Yacine (Yada on  #fedora-ds)


Version-Release number of selected component (if applicable):
FDS 1.0.1

How reproducible:
Always

Steps to Reproduce:
1. use parenthesis in a schema for an object class SUP declaration
2. restart FDS
3.
  

Actual Results:  error code 20 (Type or value exists) - object class "foo": Superior object class "(bar" does not exist


Expected Results:  Should restart without errors and take the SUP () declaration into account.

Additional info:

Comment 1 Rich Megginson 2006-02-14 14:15:52 UTC

*** This bug has been marked as a duplicate of 181465 ***

Comment 2 Chandrasekar Kannan 2008-08-11 23:43:59 UTC
Bug already CLOSED. setting screened+ flag


Note You need to log in before you can comment on or make changes to this bug.