Bug 1814651 - [UPI on OSP] Destroy playbooks do not remove image-registry swift container and cinder volumes created from PVs
Summary: [UPI on OSP] Destroy playbooks do not remove image-registry swift container a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Pierre Prinetti
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks: 1819109
TreeView+ depends on / blocked
 
Reported: 2020-03-18 12:59 UTC by David Sanz
Modified: 2020-07-13 17:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: UPI playbooks don't delete Cinder volumes created in the cluster lifetime Consequence: Destroyed OpenShift installations leak Cinder volumes Workaround (if any): Delete Cinder volumes manually after a cluster deletion Result: A paragraph has been added to the Known Issues page, inviting users to manually delete resources created day2, including Cinder volumes.
Clone Of:
: 1819109 1846296 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:22:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 3377 None closed Bug 1814651: os UPI known issues: stale resources 2020-06-17 12:07:27 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:23:02 UTC

Description David Sanz 2020-03-18 12:59:06 UTC
Description of problem:

After creating a cluster using UPI scripts, we populate the internal registry and create cinder volumes from PVs

If destroy playbooks are executed, swift container is not deleted and also cinder volumes are still present on openstack


Version-Release number of the following components:
4.4.0-0.nightly-2020-03-18-092817

How reproducible:

Steps to Reproduce:
1.Install cluster using UPI on OSP
2.Populate internal registry and create PVs using the cinder storage class
3.Execute deletion playbooks

Actual results:
Following objects are still present in the cluster, after deletion is completed:
 - Cinder volumes from PVs
 - Swift container for image registry (bootstrap container is correctly deleted)

Expected results:
All cluster related objects are deleted

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Pierre Prinetti 2020-03-23 11:12:09 UTC
In a UPI installation, the user should look after the resources they created.

A user will only use UPI if their architecture is fatally different from our Reference architecture; and those differences will likely render our teardown playbooks useless (and exponentially more so as we fine-tune them on a specific use-case).

It would indeed be handy if the playbooks did all the work the installer is doing. However for the very nature of UPI, those changes will overcomplicate the playbooks without relieving much of the user's work; they'll have to adapt the scripts anyway.

wdyt?

Comment 2 David Sanz 2020-03-25 13:16:08 UTC
I think that UPI installer should remove all elements that the IPI installer does.

If not, we should include a disclaimer in the docs about which objects have to be manually removed when UPI uninstaller playbooks ends

Comment 6 David Sanz 2020-04-01 09:10:05 UTC
Verified as fix is on the docs, not in the code

Comment 8 errata-xmlrpc 2020-07-13 17:22:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.