Bug 1846296 - [UPI on OSP] Destroy playbooks do not remove image-registry swift container
Summary: [UPI on OSP] Destroy playbooks do not remove image-registry swift container
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Pierre Prinetti
QA Contact: weiwei jiang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-11 10:29 UTC by Pierre Prinetti
Modified: 2020-10-27 16:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: cluster-image-registry-operator uses OpenStack persistence for storing its data. In the default case, that will be Swift. However, the UPI playbooks don't touch Swift. Consequence: Destroying a cluster with the UPI playbooks leaves resources in Swift. Fix: a new down-containers.yaml playbook has been added to the UPI documentation. Result: running all the down-* playbooks will now also delete Swift resources created by the cluster.
Clone Of: 1814651
Environment:
Last Closed: 2020-10-27 16:06:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3741 0 None closed Bug 1846296: openstack UPI: prune containers 2020-07-24 17:13:47 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:07:15 UTC

Description Pierre Prinetti 2020-06-11 10:29:18 UTC
+++ This bug was initially created as a clone of Bug #1814651 +++

Description of problem:

After creating a cluster using UPI scripts, a Swift container is created for CIRO.

When destroy playbooks are executed, the Swift container is not deleted.

How reproducible:

Steps to Reproduce:
1.Install cluster using UPI on OSP
2.Execute deletion playbooks

Actual results:
Following objects are still present in the cluster, after deletion is completed:
 - Swift container for image registry

Expected results:
Swift containers created during installation are not present after running the `down` playbooks.

Comment 5 errata-xmlrpc 2020-10-27 16:06:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.