Bug 181473 - "Last Session" always uses default not last session
"Last Session" always uses default not last session
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
: Reopened
: 266321 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2006-02-14 10:44 EST by William Shotts
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 15:43:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description William Shotts 2006-02-14 10:44:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
If you choose "use last session" from the session menu on the login screen, gdm always uses the default session not the last session used.

Version-Release number of selected component (if applicable):
gdm-2.13.0.8-1

How reproducible:
Always

Steps to Reproduce:
1. Log in using a non default session
2. Log out
3. Log in selecting "use last session" from the session menu
  

Actual Results:  You get the default session

Expected Results:  You get the same session as the last log in.

Additional info:

This fails with either the default session being GNOME or KDE.  It always ignores the last session.
Comment 1 Rahul Sundaram 2006-02-20 06:29:01 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 William Shotts 2006-02-20 10:03:45 EST
Issue is still present in current build.  Changed version to "devel"
Comment 3 Red Hat Bugzilla 2007-02-05 14:32:26 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 4 cje 2007-09-20 21:53:16 EDT
i think this is still happening - at least, gdm doesn't seem to remember that i
keep selecting 'online desktop' session.
Comment 5 Matthias Clasen 2007-09-21 23:26:22 EDT
Seems to be a combination of 2 problem:

1. it appears gdm does not longer try to create a ~/.dmrc if none exists

2. if I touch ~/.dmrc, I get

Sep 21 23:20:48 localhost kernel: audit(1190431248.024:106): avc:  denied  {
getattr } for  pid=7866 comm="gdm-binary" path="/home/myotherself/.dmrc"
dev=dm-1 ino=10813583 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:home_root_t:s0 tclass=file
Sep 21 23:20:48 localhost gdm-binary[7866]: GLib-CRITICAL:
g_key_file_get_string: assertion `key_file != NULL' failed
Sep 21 23:20:48 localhost kernel: audit(1190431248.024:107): avc:  denied  {
read } for  pid=7866 comm="gdm-binary" name=".dmrc" dev=dm-1 ino=10813583
scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:home_root_t:s0 tclass=file

Comment 6 Matthias Clasen 2007-09-21 23:36:05 EDT
*** Bug 266321 has been marked as a duplicate of this bug. ***
Comment 7 Ray Strode [halfline] 2007-10-01 15:43:40 EDT
This should be fixed now (from today's build), reopen if I'm wrong

Note You need to log in before you can comment on or make changes to this bug.