Bug 18150 - installer crashes on upgrade from 6.0 to 6.2 or 6.o to 7.0
Summary: installer crashes on upgrade from 6.0 to 6.2 or 6.o to 7.0
Status: CLOSED DUPLICATE of bug 13071
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL: http://crl.ucsd.edu/~elman
Whiteboard:
Keywords:
: 18330 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-02 22:05 UTC by jeff_elman
Modified: 2007-04-18 16:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-06 16:24:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is the error log that was created by the installer and saved to floppy (5.50 KB, text/plain)
2000-10-02 22:07 UTC, jeff_elman
no flags Details

Description jeff_elman 2000-10-02 22:05:09 UTC
Attempts to upgrade an i386 from 6.0 to either 6.2 or 7.0 fail at the point
where the installer is attempting to install selected packages.  The error
log
was saved to floppy and is appended.  

Jeff Elman / UC San Diego / elman@crl.ucsd.edu
=============================
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1526, in
doInstall
    self.instLog = open(self.instLogName, "w+")
IOError: [Errno 2] No such file or directory:
'/mnt/sysimage/tmp/upgrade.log'

Local variables in innermost frame:
arch: i386
total: 458
msg: File exists
logname: /tmp/upgrade.log
i: /etc/X11
p: xsysinfo
l: [abiword, adjtimex, anaconda, anacron, anonftp, apache, apmd, arpwatch,
ash, aspell, at, audiofile, aumix, authconfig, autoconf, automake, awesfx,
basesystem, bash, bc, bdflush, bind-utils, binutils, bison, bug-buddy,
byacc, bzip2, bzip2-devel, cdecl, cdp, chkconfig, chkfontpath, compat-egcs,
compat-egcs-c++, compat-glibc, compat-libstdc++, console-tools,
control-center, control-panel, cpio, cpp, cproto, cracklib, cracklib-dicts,
crontabs, ctags, cvs, cyrus-sasl, db1, db1-devel, db2, db3,
desktop-backgrounds, dev, dev86, dhcpcd, dia, dialog, diffutils, dip, dump,
e2fsprogs, ed, ee, eject, ElectricFence, elm, emacs, emacs-nox, emacs-X11,
esound, exmh, expect, extace, fetchmail, file, filesystem, fileutils,
findutils, finger, finger-server, flex, fortune-mod, freetype, ftp, gawk,
gcc, gcc-c++, gd, gdb, gdbm, gdbm-devel, gdk-pixbuf, gdm, gedit, gettext,
gftp, ghostscript, ghostscript-fonts, gimp, gimp-devel, glib, glib-devel,
glibc, glibc-devel, gmc, gmp, gnome-applets, gnome-audio,
gnome-audio-extra, gnome-core, gnome-games, gnome-libs, gnome-linuxconf,
gnome-media, gnome-pim, gnome-print, gnome-users-guide, gnome-utils,
gnorpm, gnotepad+, gnumeric, gnupg, gpm, gpm-devel, gqview, grep, groff,
groff-perl, gtk+, gtk+-devel, gtk-engines, gtop, guile, gv, gzip, hdparm,
ical, ImageMagick, imlib, imlib-cfgeditor, imlib-devel, indexhtml, inews,
info, initscripts, iputils, isapnptools, kbdconfig, kdebase, kdelibs,
kdelibs-devel, kdesupport, kdesupport-devel, kernel, kernel-doc,
kernel-headers, kernel-pcmcia-cs, kernel-source, kernel-utils, kgcc,
krb5-libs, kudzu, less, libghttp, libglade, libgtop, libjpeg,
libjpeg-devel, libpng, libpng-devel, librep, libstdc++, libstdc++-devel,
libtermcap, libtermcap-devel, libtiff, libtiff-devel, libtool,
libtool-libs, libungif, libungif-devel, libxml, lilo, linuxconf, logrotate,
losetup, LPRng, lrzsz, lsof, lynx, m4, mailcap, mailx, make, MAKEDEV, man,
man-pages, mc, Mesa, metamail, mikmod, mingetty, minicom, mkbootdisk,
mkinitrd, mktemp, mkxauth, modemtool, modutils, mount, mouseconfig, mpage,
mt-st, multimedia, mutt, ncftp, ncompress, ncurses, ncurses-devel,
ncurses4, net-tools, netcfg, netpbm, netpbm-devel, netpbm-progs,
netscape-common, netscape-communicator, newt, newt-devel, nfs-utils, nmh,
ntsysv, openldap, openssh, openssh-askpass, openssh-askpass-gnome,
openssh-clients, openssl, ORBit, pam, passwd, patch, pciutils, perl, pine,
playmidi, playmidi-X11, pmake, popt, portmap, ppp, printtool, procmail,
procps, psmisc, pspell, pump, pwdb, pygnome-libglade, pygtk-libglade,
python, pythonlib, qt, qt1x, qt1x-devel, quota, raidtools, rcs, rdate,
rdist, readline, readline-devel, redhat-logos, redhat-release, rep-gtk,
rep-gtk-gnome, rep-gtk-libglade, rhs-printfilters, rmt, rootfiles, rp3,
rpm, rpm-build, rpm-devel, rpm-python, rsh, rsh-server, rsync, rusers,
rusers-server, rwall-server, rwho, rxvt, samba, samba-client, samba-common,
sash, sawfish, screen, sed, sendmail, setserial, setup, setuptool,
sh-utils, shadow-utils, sharutils, slang, slang-devel, slocate, slrn,
sndconfig, sox, stat, statserial, strace, stunnel, switchdesk,
switchdesk-gnome, sysklogd, SysVinit, talk, talk-server, tar, tcl, tclx,
tcp_wrappers, tcsh, telnet, telnet-server, termcap, tetex, tetex-fonts,
tetex-xdvi, texinfo, textutils, tftp-server, time, timeconfig, timetool,
tin, tix, tk, tkinter, tksysv, tmpwatch, traceroute, trn, umb-scheme,
unzip, urlview, urw-fonts, usermode, utempter, util-linux, vim-common,
vim-minimal, vixie-cron, which, whois, words, wu-ftpd, wvdial, Xaw3d,
xchat, Xconfigurator, XFree86, XFree86-100dpi-fonts, XFree86-3DLabs,
XFree86-75dpi-fonts, XFree86-8514, XFree86-AGX, XFree86-cyrillic-fonts,
XFree86-devel, XFree86-doc, XFree86-FBDev, XFree86-I128, XFree86-libs,
XFree86-Mach32, XFree86-Mach64, XFree86-Mach8, XFree86-Mono, XFree86-SVGA,
XFree86-tools, XFree86-twm, XFree86-VGA16, XFree86-xdm, XFree86-xf86cfg,
XFree86-xfs, XFree86-Xnest, XFree86-Xvfb, xinetd, xinitrc, xloadimage,
xmailbox, xmms, xmorph, xpaint, xpdf, xrn, xscreensaver, xsri, xxgdb, zip,
zlib, zlib-devel, db2-devel, db3-devel, db3-utils, enlightenment, enscript,
fetchmailconf, fnlib, freetype-devel, freetype-utils, fvwm2, fvwm2-icons,
getty_ps, giftrans, glib10, glibc-profile, gnuplot, groff-gxditview,
gtk+10, imap, ircii, libjpeg6a, libpcap, libungif-progs, licq, macutils,
mcserv, mysql, mysql-server, ntp, psacct, python-docs, python-tools,
readline2.2.1, routed, rwall, sawfish-themer, sendmail-cf, symlinks, tftp,
timed, transfig, tree, uucp, vim-enhanced, vim-X11, wmconfig, xcpustate,
xfig, xmms-gnome, xosview, xsysinfo]
db: <rpmdb object at 91dfa40>
self: <todo.ToDo instance at 827c7b0>
how: u
errno: 17
totalSize: 1093508
f: <closed file '/mnt/sysimage/etc/mtab', mode 'w+' at 9238880>
ts: <rpmtrans object at 922b128>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>

Comment 1 jeff_elman 2000-10-02 22:07:05 UTC
Created attachment 3638 [details]
this is the error log that was created by the installer and saved to floppy

Comment 2 Michael Fulbright 2000-10-03 20:20:10 UTC
Please verify Brent.

I would recommend setting up a 6.2 box, put  a upgrade.log file in /tmp and do
an upgrade and see if you get this error.

Comment 3 Michael Fulbright 2000-10-05 16:42:50 UTC
*** Bug 18330 has been marked as a duplicate of this bug. ***

Comment 4 jeff_elman 2000-10-05 21:27:13 UTC
This problem appears to arise whenever the installer needs to access a file or
directory that has been symlinked to / (or that  falls in the hierarchy below
a symblink).  Thus if either /tmp or /var/lib are symlinks, the installer will
fail.

The user workaround is to make sure that no files or directories that are
accessed
by the installer involve symlinks.


Comment 5 Michael Fulbright 2000-10-06 16:24:53 UTC

*** This bug has been marked as a duplicate of 13071 ***


Note You need to log in before you can comment on or make changes to this bug.