Bug 1815138 - Disk import activity fails if datavolume does not have owner reference
Summary: Disk import activity fails if datavolume does not have owner reference
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Rastislav Wagner
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks: 1815141
TreeView+ depends on / blocked
 
Reported: 2020-03-19 15:11 UTC by Rastislav Wagner
Modified: 2020-08-04 18:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Any DataVolume is considered as VM Disk import which is not correct. This also causes Activity card to fail (disappear) Consequence: Activity card expects that DataVolume has owner reference set which is not always the case. Fix: Only DataVolumes with owner reference to VM are considered as VM disk import activity. Result: Activity card wont disappear anymore if there's DataVolume without owner reference.
Clone Of:
: 1815141 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:06:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4776 None closed Bug 1815138: Filter out datavolumes which do not have owner reference 2020-07-01 16:17:33 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:06:12 UTC

Description Rastislav Wagner 2020-03-19 15:11:02 UTC
Description of problem:

If DataVolume does not contain reference to VM, it should not be considered as VM Disk import activity. 


How reproducible:
Create DataVolume manually and check Dashboards page - activity card will disappear as created DV does not contain owner reference to VM

Comment 3 Guohua Ouyang 2020-03-30 08:25:01 UTC
I could reproduce the issue with OCP 4.4. 
And the issue is gone when run UI under development mode from master.

Comment 4 Guohua Ouyang 2020-03-31 01:56:03 UTC
verified on 4.5.0-0.nightly-2020-03-29-224016

Comment 6 errata-xmlrpc 2020-08-04 18:06:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.