Bug 1815141 - Disk import activity fails if datavolume does not have owner reference
Summary: Disk import activity fails if datavolume does not have owner reference
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Rastislav Wagner
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On: 1815138
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-19 15:14 UTC by Rastislav Wagner
Modified: 2020-05-04 11:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1815138
Environment:
Last Closed: 2020-05-04 11:47:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4807 None closed [release-4.4] Bug 1815141: Filter out datavolumes which do not have owner reference 2020-04-30 11:55:42 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:47:24 UTC

Description Rastislav Wagner 2020-03-19 15:14:42 UTC
+++ This bug was initially created as a clone of Bug #1815138 +++

Description of problem:

If DataVolume does not contain reference to VM, it should not be considered as VM Disk import activity. 


How reproducible:
Create DataVolume manually and check Dashboards page - activity card will disappear as created DV does not contain owner reference to VM

Comment 1 Nelly Credi 2020-03-31 10:47:53 UTC
I see the 4.5 bug was verified, can this bug get pushed now?

Comment 2 Tomas Jelinek 2020-03-31 11:03:51 UTC
yes, the PR has been created and fully acked, so now just waiting until all the automation passes and than it will be merged some time after

Comment 5 Guohua Ouyang 2020-04-07 01:54:25 UTC
verified on 4.4.0-rc.6.

Comment 7 errata-xmlrpc 2020-05-04 11:47:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.