Bug 181547 - reboot screws up xm list
reboot screws up xm list
Status: CLOSED DUPLICATE of bug 179677
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-14 16:45 EST by Michael Richardson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 21:59:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Richardson 2006-02-14 16:45:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050927 Epiphany/1.4.8 (Debian)

Description of problem:
I typed "reboot" in a domU.
It shutdown, but didn't reboot.

I then exited the console, and did "xm destroy ns2"


trout-[/etc/xen] root 30 #xm destroy ns2  
Error: Internal server error

trout-[/etc/xen] root 31 #xm create -c ns2
Using config file "ns2".
Going to boot Fedora Core (2.6.15-1.43_FC5guest)
  kernel: /vmlinuz-2.6.15-1.43_FC5guest
  initrd: /initrd-2.6.15-1.43_FC5guest.img
Error: Error creating domain: VM name 'ns2' already in use by domain 12

trout-[/etc/xen] root 33 #xm list
Unexpected error: xen.xend.XendProtocol.XendError

Please report to xen-devel@lists.xensource.com
Traceback (most recent call last):
  File "/usr/sbin/xm", line 10, in ?
    main.main(sys.argv)
  File "/usr/lib/python2.4/site-packages/xen/xm/main.py", line 906, in main
    rc = cmd(args)
  File "/usr/lib/python2.4/site-packages/xen/xm/main.py", line 356, in xm_list
    doms = getDomains(params)
  File "/usr/lib/python2.4/site-packages/xen/xm/main.py", line 332, in getDomains
    return server.xend_list_domains()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendClient.py", line 200, in xend_list_domains
    return self.xendGet(self.domainurl(), {'detail': '1'})
  File "/usr/lib/python2.4/site-packages/xen/xend/XendClient.py", line 150, in xendGet
    return self.client.xendGet(url, args)
  File "/usr/lib/python2.4/site-packages/xen/xend/XendProtocol.py", line 92, in xendGet
    return self.xendRequest(url, "GET", args)
  File "/usr/lib/python2.4/site-packages/xen/xend/XendProtocol.py", line 182, in xendRequest
    resp.reason)
  File "/usr/lib/python2.4/site-packages/xen/xend/XendProtocol.py", line 112, in handleStatus
    return self.handleException(XendError(message))
  File "/usr/lib/python2.4/site-packages/xen/xend/XendProtocol.py", line 138, in handleException
    raise err
xen.xend.XendProtocol.XendError: Internal server error
zsh: 7087 exit 1     xm list


Version-Release number of selected component (if applicable):
xen-3.0-0.20060130.fc5.6

How reproducible:
Didn't try


Additional info:
Comment 1 Rahul Sundaram 2006-02-20 06:12:42 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Rik van Riel 2006-02-20 21:59:30 EST

*** This bug has been marked as a duplicate of 179677 ***

Note You need to log in before you can comment on or make changes to this bug.