Bug 179677 - xend throws exception on reboot of domain
xend throws exception on reboot of domain
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 181547 182295 182321 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-01 18:58 EST by Dan Young
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 18:21:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/xend-debug.log (1.95 KB, text/plain)
2006-02-01 18:59 EST, Dan Young
no flags Details

  None (edit)
Description Dan Young 2006-02-01 18:58:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
"xm list" gives this traceback after doing a "shutdown -r now" in a domain:

Traceback (most recent call last):
  File "/usr/sbin/xm", line 10, in ?
    main.main(sys.argv)
  File "/usr/lib/python2.4/site-packages/xen/xm/main.py", line 906, in main
    rc = cmd(args)
  File "/usr/lib/python2.4/site-packages/xen/xm/main.py", line 356, in xm_list
    doms = getDomains(params)
  File "/usr/lib/python2.4/site-packages/xen/xm/main.py", line 332, in getDomains
    return server.xend_list_domains()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendClient.py", line 200, in xend_list_domains
    return self.xendGet(self.domainurl(), {'detail': '1'})
  File "/usr/lib/python2.4/site-packages/xen/xend/XendClient.py", line 150, in xendGet
    return self.client.xendGet(url, args)
  File "/usr/lib/python2.4/site-packages/xen/xend/XendProtocol.py", line 92, in xendGet
    return self.xendRequest(url, "GET", args)
  File "/usr/lib/python2.4/site-packages/xen/xend/XendProtocol.py", line 182, in xendRequest
    resp.reason)
  File "/usr/lib/python2.4/site-packages/xen/xend/XendProtocol.py", line 112, in handleStatus
    return self.handleException(XendError(message))
  File "/usr/lib/python2.4/site-packages/xen/xend/XendProtocol.py", line 138, in handleException
    raise err


Version-Release number of selected component (if applicable):
xen-3.0-0.20060130.fc5.2

How reproducible:
Always

Steps to Reproduce:
1. xm create -c foo
2. Log in to foo
3. shutdown -r now
4. "xm list" in dom0
  

Actual Results:  Traceback in description. /var/log/xend-debug.log will be attached. xentop shows foo in shutdown state.

Expected Results:  foo should reboot.

Additional info:

Can "/etc/init.d/xend restart" to recover.
Comment 1 Dan Young 2006-02-01 18:59:39 EST
Created attachment 124020 [details]
/var/log/xend-debug.log
Comment 2 Rik van Riel 2006-02-08 21:21:10 EST
I'm seeing it here, too.

Jeremy, do you want to take a stab at this? (you seem to be looking at the tools
lately).
Comment 3 Rik van Riel 2006-02-20 21:59:45 EST
*** Bug 181547 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2006-02-22 15:31:09 EST
*** Bug 182321 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2006-02-23 17:15:17 EST
*** Bug 182295 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2006-02-23 18:21:13 EST
Fixed in CVS for 3.0.1-0.20060208.fc5.3

Note You need to log in before you can comment on or make changes to this bug.