Bug 181589 - VolGroup00 if the / filesystem is on an extended partition
VolGroup00 if the / filesystem is on an extended partition
Status: CLOSED DUPLICATE of bug 160693
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 19:16 EST by Graeme McRae
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 14:49:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graeme McRae 2006-02-14 19:16:08 EST
Description:
I left a 16269MB windows partition on hda1, and defined three other partitions 
myself in preparation for installing fc4.

hda2 is 100M, for /boot

hda3 is 8192M, LVM type, for / and /swap

hda5 is 11264M, LVM type, for /usr/local, /usr, and /home

Interestingly, as I added the partitions, the installation tool switched hda3 
and hda5, deciding for whatever reason to put the larger one in a primary 
partition, and leaving the / filesystem in an extended partition.  I have a 
strong feeling this is a no-no, and if so, the real bug comes next:

In hda5 (the extended partition) I defined VolGroup00, containing LogVol00, 
mounted as /, and LogVol01 for swap.

In hda3 (the primary partition) I defined VolGroup51, containing LogVol51, 
LogVol52, and LogVol53, mounted as /usr/local, /usr, and /home, respectively.

I selected packages, clicked OK, and boom!

Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 1137, in handelRenderCallback 
self.currentWindow.renderCallback()
File "/usr/lib/anaconda/rw/progress_gui.py", line 244, in renderCallback 
self.initf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 873, in nextClicked self.dispatch.gotoNext
()
File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep rc = apply(func, 
self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 582, in turnOnFilesystems 
thefsset.createLogicalVolumes(instPath)
File "/usr/lib/anaconda/fsset.py", line 1472, in createLogicalVolumes 
entry.device.setupDevice(chroot)
File "/usr/lib/anaconda/fsset.py", line 2088, in setupDevice raise 
SystemError, "vgcreate failed for %s" %(self.name,)
SystemError: vgcreate failed for VolGroup00

Steps to reproduce:
1. Start with just one Windows partition, and at least 20 gigs of free space
2. Run anaconda
3. Define logical volumes manually, stupidly not checking the "force primary" 
box for the LVM partition that will be used for the / filesystem.

Actual results:
See Description, above.

Workaround: check the box that says "force this partition to be primary" for 
the partition that will contain the / filesystem and swap file.

Expected results:
It should have made whirring noises, asked me to slide four CDs into the 
computer in succession, and then congratulated me after installation was 
complete.

Additional information:
If the / filesystem can't be on an extended partition, then as soon as you try 
to move into the package selection phase of the installation, you should get a 
strongly worded complaint saying that you're about to do something very stupid, 
and to please reconsider.

If the / filesystem can be on an LVM extended partition, then there must be 
some other bug that prevents creating the VolGroup00 volume group.  I just 
don't know enough about Linux to know which is the case.
Comment 1 Jeremy Katz 2006-02-15 14:49:25 EST

*** This bug has been marked as a duplicate of 160693 ***

Note You need to log in before you can comment on or make changes to this bug.