Bug 18170 - Cannot execute gnumeric of 7.0J
Cannot execute gnumeric of 7.0J
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-print (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
: 18222 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-02 22:57 EDT by Mitsuo Hamada
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-24 18:59:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mitsuo Hamada 2000-10-02 22:57:20 EDT
After upgrading from 6.2J to 7.0J, I cannot execute gnumeric.
An error dialog tells me that "Gnumeric failed to find a suitable
default font. Please verify your gnome-print installation and that
your fontmap file is not empty or near empty."

I verified gnome-print was installed correctly. But I found
fonts.dir files are empty under /usr/share/fonts/.
Comment 1 David Mason 2000-10-03 11:17:10 EDT
*** Bug 18222 has been marked as a duplicate of this bug. ***
Comment 2 Matt Wilson 2000-12-29 18:57:25 EST
this is a gnome-print bug, not gnumeric.
Comment 3 Need Real Name 2001-01-01 18:26:16 EST
I too have the symptom of 18222 (upgraded from 6.2 to 7.0 non-japanese and
gnumeric fails due to gnome-print)

Does anyone have a workaround for this?  I'd really like to be able to use
gnumeric.
Comment 4 Mike Baptiste 2001-02-24 18:59:02 EST
I think the problems is with the /usr/share/fonts/fontmap file

Its empty in my installation (RH7, Ximian GNOME)

Apparently, when gnome-print is installed, there is already a fontmap file
(empty) and it doesn't get replaced.  Well, I did the following for kicks after
downloading the rpms from rpmfind.

  rpm -U --force gnome-core-1.2.4-0_helix_2.i386.rpm
  rpm -U --force libgnomeprint11-0.25-8_helix_1.i386.rpm
  rpm -U --force gnome-print-0.25-8_helix_1.i386.rpm 

When I reinstalled the gnome-print packaage, it returned
"/usr/shar/fonts/fontmap  and sure enough, teh file was now packed with font
information.  You can probably get away with just reinstalling the gnome-print
package with the --force option.

Now gnumeric starts for me!  Cool!
Comment 5 Owen Taylor 2001-07-21 20:18:49 EDT
This should be fixed with the gnome-print-0.29-2 package, which
changes the handling of the fontmap file quite a bit. I don't
know the exact problems which were causing bad fontmap files,
but I'm pretty sure that the new package should work OK.

(Note this pakcage is a different soname, so will require upgrades
of gnumeric, abiword, gedit)

Note You need to log in before you can comment on or make changes to this bug.