Bug 181719 - Connected USB drive prevents installer CD from starting
Connected USB drive prevents installer CD from starting
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks: F8KernelBlocker
  Show dependency treegraph
 
Reported: 2006-02-15 18:56 EST by John Pye
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 11:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Pye 2006-02-15 18:56:51 EST
Description of problem:
I downloaded the FC5 test 2 CD, disc 1, and inserted it into my machine.
I plugged in my USB drive and rebooted the machine.
I entered BIOS and told BIOS to boot from CD first.
I rebooted and the 'Fedora' screen came up. I hit 'enter' and after the initrd
and vmlinuz ....... stuff came up, the screen blanked and just a flashing 
underscore showed in the top left.
I repeated without the USB drive, and the installer ran normally, as expected.

Version-Release number of selected component (if applicable):
FC5 test 2

How reproducible:
Every time. Two different machines. The USB drive is readable from Windows, from
FC4 after bootup, and from the Ubuntu installer CD. FC4 and FC5 don't seem to be
capable to detecting it properly during boot from CD.

Steps to Reproduce:
1. as above.
  
Actual results:
Hangs on boot from CD

Expected results:
AT least the CD should give a message saying that I can't boot with a USB drive
connected to the syste. Ideally, I should be offered the option to install to
the USB drive.

Additional info:
Comment 1 John Pye 2006-02-15 18:58:49 EST
To clarify: at the flashing underscore, the system hangs indefinitely. I left it
for 20 minutes, nothing happened. There are some indications on the forums that
other people have seen this as well.
Comment 2 Rahul Sundaram 2006-02-20 06:35:27 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 John Pye 2006-02-20 20:58:57 EST
Bug is still present with FC5 test 3. Nothing whatsoever has changed.
Comment 4 Greg Morgan 2006-03-30 21:16:59 EST
I tried this on FC5 production.  I booted from the CD along with a USB drive.  I
booted just fine and saw all the normal anaconda starting USB mass storage
messages on into the anaconda GUI.  This is on an older ecs motherboard that
does not let me boot from USB.  I will try on another computer later.
Comment 5 Greg Morgan 2006-03-31 00:37:08 EST
I tried this on FC5 production.  I tried two attempts.  Both had the CD-r and
USB device ready at boot time.  In the first attempt, I had my boot order of
floppy, cd-rom hd-0 in bios along with try other boot devices.  FC5 booted to
the GUI anaconda screen. In the second attempt, I set the USB device as the
first boot device. The usb stick did not have a boot sector.  I received an
error that passed onto the CD-rom.  The system continued all they way to the GUI
anaconda screen.
NOTES: I am using ATA drives and not SATA with a generic ECS KT600-A motherboard.

Perhaps the key questions, so to speak ;-) How was your USB stick formatted?  I
believe the USB 1.x storage spec says that the device must be fat/vfat.  I don't
have a stick to try this on.  As I recall if you ext2/ext3 format the device,
then the system will still boot but you won't see anaconda say, "Starting Usb
mass storeage...".

So is this bug good enough to close then or would it be interesting to hear what
John Pye has to say about his configuration?
Comment 6 John Pye 2006-03-31 00:55:39 EST
Hi,

I was trying this not with a USB stick but with a USB hard drive, 80 GB. It is
detected and can be installed to on newer computers, but on older like the one
I'm on now, the BIOS says it can boot from USB, but the Fedora CD fails to
launch properly when the USB drive is connected.

The motherboard seems to be an Intel D845GBV. At least that's what it says on
the sticker that the manufacturer gave me. Also says on the sticker 'A84662-001'.

While on a newer computer, I managed to install Ubuntu 5.10 on my USB hard
drive. It works great, but all my attempts to run it from my older computer
result in a GRUB error at 'stage 1.5', error 16. This appears to be something
that's coming in to effect BEFORE the OS has loaded. So I'm worried that even if
I pursuade Fedora to install itself onto my USB drive, my particular BIOS or
motherboard or whatever isn't going to let me boot it anyway. I tried asking the
GRUB list about this, but no response. Also tried various Fedora and Ubuntu
forums but no tips either. 

Think my computer is like one of those kids who will never learn to ride a
bicycle and not for want of trying :-)


Comment 7 Greg Morgan 2006-06-05 01:52:54 EDT
I see what you're doing.  You're not trying to use a USB stick or drive during
anaconda install as a tool but you want to use the resulting usb drive as your
boot drive.  Interesting: So I goolged on "grub error 16" without the quotes.  I
think the link to look at is this one since you say you have older hardware
involved: http://lists.suse.com/archive/suse-linux-e/2005-Dec/0411.html. Even
for the 80gig drive that you are using try a small boot partition just like a
normal install. 100 to 250 meg.

"Here is a quick one I came across today which I ended up using deductive
reasoning over the Internet, Grub error 16.

" Cause: /boot existed on partition that spanned past the 127 GB mark on older
P4 system.

"Solution: Explicitly set up /boot on small partition (32 MB in this case)
below the 127 GB mark.

"Other symtom(s): LILO errored out when LILO install tool was run.

"--Jason Snyder-- 


Others: look for slash syntax errors.
http://tastytronic.net/pipermail/pocket-linux/2003-September/000070.html

Some other grub notes
http://forums.gentoo.org/viewtopic.php?t=122656
Error code list http://www.linuxselfhelp.com/gnu/grub/html_chapter/grub_13.html

People doing the same
http://forums.suselinuxsupport.de/lofiversion/index.php/t17710.html
http://forums.suselinuxsupport.de/lofiversion/index.php/t27119.html

Note that I am interested in writing about installing from a USB drive here
http://fedoraproject.org/wiki/AnacondaBoot .  Hence the interest in your
problem.  You also might want to chect out the initial USB Notes section.  Check
how you partitioned and formated the drive.   The partition size again could
cause problems.  In the article I want to use the hard drive on MS Windows too.
 What are you using for your file system on your USB Drive to attempt the install?

HTH
Greg
Comment 8 Dave Jones 2006-10-16 15:56:26 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 9 John Pye 2006-10-17 06:55:21 EDT
How can I possibly test this? The FC5 installer CD won't have changed, so the
problem will still be there. Or is there somewhere I can get a new installer CD
with the new kernel version that you're describing?

In response to Greg's comments:

The goal here is to place a USB drive into the machine, then boot the FC5
installer CD and for FC5 to recognize that drive (*regardless* of what's on it,
or whether it's unformatted, etc, etc) and for FC5 to offer me the usual
partitioning options on my various drives, *including* the USB hard drive. If I
connect the USB drive after initial boot, it doesn't show up. If I connect it
before initial boot, the installer doesn't start.

It seems that I must wait until FC6 comes out, and try it then, eh?

I would reiterate that I had success with Ubuntu installer but not with FC5. So
presumably we're looking at issues with anaconda or something like that, rather
than linux itself?


Cheers
JP
Comment 10 Dave Jones 2006-10-18 02:37:22 EDT
Short of trying FC6 when that arrives, the only other alternative is the
fedoraunity.org project, which does respins of older releases+updates.
It's been a while since they last did one, but you may get lucky if this has
been fixed in upstream since 2.6.15 on which FC5 was based.

Something else that might be interesting to test would be to try the ub driver
instead of usb-storage.  You can test this by booting with the option

libusual.bias=ub
Comment 11 Leslie Satenstein 2007-04-01 22:14:01 EDT
Same problem in FC7. I have a 250 gig usb drive formatted ext3, and it stopped
the install of FC7.  
Comment 12 Jeremy Katz 2007-05-22 15:46:04 EDT
Does this still happen with rawhide? 
Comment 13 Will Woods 2007-10-18 11:29:29 EDT
I'm unable to reproduce this. Has anyone who originally reported this problem
tried installing F8Test3?
Comment 14 Will Woods 2007-10-24 11:34:44 EDT
Nobody's been able to reproduce this at all with F8 pre-releases. No response
from reporters. Closing INSUFFICIENT_DATA. 

Note You need to log in before you can comment on or make changes to this bug.