This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 181727 - unable to print in gu_IN locale
unable to print in gu_IN locale
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: i18n, Translation
: 195483 (view as bug list)
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-02-15 19:41 EST by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.16.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 23:00:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fixed gu.po (32.73 KB, application/x-tar)
2006-08-25 04:42 EDT, Akira TAGOH
no flags Details

  None (edit)
Description Lawrence Lim 2006-02-15 19:41:47 EST
Description of problem:
Checked with pa_IN and bn_IN, both were able to print ok in their respective
locale. However, in gu_IN locale, nothing gets printed and some error have been
found.


Version-Release number of selected component (if applicable):
gedit-2.13.90-3.1

How reproducible:
Always

Steps to Reproduce:
1.start gedit in gu_IN locale
2.copy and paste any form of text (en is OK) into gedit
3.print
  
Actual results:
Nothing happens. Following message was found:

# gedit
Model not found, discarding config

(gedit:15784): GnomePrintCupsPlugin-WARNING **: iconv does not support ppd
character encoding: MacStandard, trying CSISOLatin1

(gedit:15784): GnomePrintCupsPlugin-WARNING **: iconv does not support ppd
character encoding: ISOLatin1, trying CSISOLatin1
GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer printer could
not be loaded.
style-set
sys:1: PangoWarning: pango_context_load_font: assertion
`pango_font_description_get_size (desc) != 0' failed

Expected results:
able to print

Additional info:
Comment 1 Rahul Sundaram 2006-02-20 06:32:27 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Leon Ho 2006-07-12 23:42:13 EDT
Look like a libgnomeprint/pango bug. Changing the component libgnomeprint first.
Comment 3 Leon Ho 2006-07-12 23:43:18 EDT
*** Bug 195483 has been marked as a duplicate of this bug. ***
Comment 4 Akira TAGOH 2006-08-25 03:59:14 EDT
this seems to be introduced by mistranslation - Why the fontname and the
fontsize is included in the po file is, allowing people to adjust them for their
languages' favorite fontname or fontsize. if the fontname is 'Sans', 'Serif' and
'Monospace', normally they should works for any laugnages though. so if they
appears in the po file, it doesn't mean to translate them to the native
language. i.e.

msgid "Sans 11"
msgstr "સાન્સ ૧૧"

msgid "Sans 8"
msgstr "સાન્સ ૮"

msgid "Sans Regular 11"
msgstr "નિયમિત સાન્સ ૧૧"

msgid "Sans Regular 8"
msgstr "નિયમિત સાન્સ ૮"

are definitely wrong. reassigning to gedit.
Comment 5 Akira TAGOH 2006-08-25 04:42:40 EDT
Created attachment 134898 [details]
fixed gu.po

attached correct gu.po.
Comment 6 Akira TAGOH 2006-09-07 03:50:54 EDT
erm, actually no lucks with the above fix. however the Gujarati text printing on
gedit strangely works on other locale and just removing the whole of .mo files
didn't help. so need to investigate this issue much further.
Comment 7 Akira TAGOH 2006-09-07 09:36:03 EDT
doh! sorry for false alarm - I should rebuild gedit with the updated gu.po
instead of copying gedit.mo that converted from it. it doesn't help anything at
all since the real font configuration is in gconf schemas and it contains the
translated stuff too that generated at the build time.

So using the above gu.po exactly fixes this issue. I saw the updated gu.po is
committed into upstream CVS. so hopefully this will be fixed in next release if
we will ship gedit-2.6.0. otherwise we need to apply this into our package.
Comment 8 Matthias Clasen 2006-09-07 23:00:25 EDT
I see the issue in gu.po is fixed in 2.16.0 that is currently in rawhide.
But I see a few other broken translations of Sans in gedit/po/*:

vi.po:

msgid "Sans 11"
msgstr "12 điểm không gạch chân"

I'll file an upstream bug about that.

Note You need to log in before you can comment on or make changes to this bug.