Bug 1817879 - Line divider is missing between Machine Health Checks and Machine Configs
Summary: Line divider is missing between Machine Health Checks and Machine Configs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1819287
TreeView+ depends on / blocked
 
Reported: 2020-03-27 08:02 UTC by Yadan Pei
Modified: 2020-08-04 18:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Missing line divider between Machine Health Checks and Machine Config. Consequence: Machine Health Checks and Machine Config are not visually separated. Fix: Add divider between Machine Health Checks and Machine Config. Result: Divider between Machine Health Checks and Machine Config.
Clone Of:
Environment:
Last Closed: 2020-08-04 18:07:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
4.3 Line Breaker Missing (164.05 KB, image/png)
2020-03-27 08:07 UTC, Yadan Pei
no flags Details
4.4 Line Breaker Exists (165.84 KB, image/png)
2020-03-27 08:08 UTC, Yadan Pei
no flags Details
4.5 Line Breaker Exists (188.49 KB, image/png)
2020-03-27 08:09 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:07:19 UTC

Description Yadan Pei 2020-03-27 08:02:27 UTC
Description of problem:
As title

Version-Release number of selected component (if applicable):
4.3.9

How reproducible:
Always

Steps to Reproduce:
1. cluster admin user login and check sub menus in Compute 
2.
3.

Actual results:
1. No line divider between Machine Health Checks and Machine Configs, see screenshot 

Expected results:
1. in 4.4 and 4.5, we show line divider between Machine Health Checks and Machine Configs, see screenshot

Additional info:

Comment 1 Yadan Pei 2020-03-27 08:07:42 UTC
Created attachment 1673983 [details]
4.3 Line Breaker Missing

Comment 2 Yadan Pei 2020-03-27 08:08:25 UTC
Created attachment 1673984 [details]
4.4 Line Breaker Exists

Comment 3 Yadan Pei 2020-03-27 08:09:17 UTC
Created attachment 1673985 [details]
4.5 Line Breaker Exists

Comment 4 Jakub Hadvig 2020-03-27 09:29:16 UTC
Was testing the 4.3 release from the console repo and wasnt able to reproduce the issue.
Tested both on FF and Chrome.
Also the code for the separator is in place for 4.3: 
https://github.com/openshift/console/blob/release-4.3/frontend/public/components/nav/admin-nav.tsx#L214

Could you maybe provide additional info on which browser you are using ?

Comment 5 Yadan Pei 2020-03-30 02:22:50 UTC
Hi Jakub,

I reproduced this issue on 4.3.0-0.nightly-2020-03-29-181428, FF 74.0 (64-bit) && Chrome 80.0.3987.149 (Official Build)

Comment 8 Yadan Pei 2020-04-01 02:26:35 UTC
clear NEEDINFO since comment is already provided

Comment 9 Yadan Pei 2020-04-01 03:27:57 UTC
Moving to VERIFIED since the issue do not exist on 4.5.0-0.nightly-2020-03-31-203533

Comment 11 errata-xmlrpc 2020-08-04 18:07:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.