Bug 1818420 - CSR signer didn't recover
Summary: CSR signer didn't recover
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Tomáš Nožička
QA Contact: zhou ying
URL:
Whiteboard:
: 1821680 1827990 (view as bug list)
Depends On:
Blocks: 1817997 1821683 1827990
TreeView+ depends on / blocked
 
Reported: 2020-03-28 01:09 UTC by Xingxing Xia
Modified: 2020-08-04 18:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1817997
: 1827990 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:07:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-controller-manager-operator pull 382 0 None closed Bug 1818420: delay only when csr-signer is from the future 2020-09-07 09:58:40 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-08-04 18:07:34 UTC

Comment 4 Maciej Szulik 2020-04-08 08:27:00 UTC
This fix partially addresses the problem, the other half was from https://bugzilla.redhat.com/show_bug.cgi?id=1820610 
so they should be tested in parallel.

Comment 6 Xingxing Xia 2020-04-08 10:48:10 UTC
OK, thanks.

Comment 7 Maciej Szulik 2020-04-27 09:18:51 UTC
I'm closing the other one as we prefer to keep the full history which is already here, and I'm moving this back to dev.

Comment 8 Maciej Szulik 2020-04-27 09:20:34 UTC
*** Bug 1827990 has been marked as a duplicate of this bug. ***

Comment 10 Tomáš Nožička 2020-05-04 14:58:03 UTC
I am closing the CSR signer issues as a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1821680 where the issue and the fix were tracked and verified.

*** This bug has been marked as a duplicate of bug 1821680 ***

Comment 11 Tomáš Nožička 2020-05-04 14:59:33 UTC
note that the kube-apiserver client CA reloading is being tracked in BZ https://bugzilla.redhat.com/show_bug.cgi?id=1831042

Comment 12 Xingxing Xia 2020-05-05 07:02:10 UTC
*** Bug 1821680 has been marked as a duplicate of this bug. ***

Comment 13 Tomáš Nožička 2020-05-05 11:54:43 UTC
xxia why did you change it this way? 

I think https://bugzilla.redhat.com/show_bug.cgi?id=1821683 should be verified as it was the PR used to merge https://github.com/openshift/cluster-kube-controller-manager-operator/pull/393 and was verified in https://bugzilla.redhat.com/show_bug.cgi?id=1821683#c3. This PR wasn't verified.

Comment 16 errata-xmlrpc 2020-08-04 18:07:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.