Bug 1818722 - [4.5]label with long value is overlapping another one
Summary: [4.5]label with long value is overlapping another one
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Andrew Pickering
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1800494
Blocks: 1760758 1837784
TreeView+ depends on / blocked
 
Reported: 2020-03-30 08:22 UTC by Junqi Zhao
Modified: 2020-07-13 17:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1800494
Environment:
Last Closed: 2020-07-13 17:24:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification screenshot (144.18 KB, image/png)
2020-05-19 03:11 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5473 0 None closed Bug 1818722: Query Browser: Add text wrapping for table headers 2020-06-28 01:00:50 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:24:33 UTC

Description Junqi Zhao 2020-03-30 08:22:01 UTC
+++ This bug was initially created as a clone of Bug #1800494 +++

+++ This bug was initially created as a clone of Bug #1760758 +++

Description of problem:
search kube_persistentvolumeclaim_info in Query Browser
see the picture, label persistentvolumeclaim is overlapping label pod, length for persistentvolumeclaim is 22


Version-Release number of selected component (if applicable):
4.2.0-rc.5
firefox 66.0.4 (64-bit)
Chrome	75.0.3770.90 (Official Build) (64-bit)

How reproducible:
label with long value

Steps to Reproduce:
1. See the description
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Junqi Zhao on 2019-11-29 07:08:43 UTC ---

same issue for node_role_os_version_machine:cpu_capacity_cores:sum

--- Additional comment from Junqi Zhao on 2019-11-29 07:09:19 UTC ---

--- Additional comment from Junqi Zhao on 2020-02-07 09:32:55 UTC ---

admin/developer console have the same issue

--- Additional comment from Samuel Padgett on 2020-02-07 14:18:36 UTC ---

Ideally, we would have a fix for https://github.com/patternfly/patternfly-next/issues/2584

The monitoring dashboard tables use these style to prevent the headers overlapping:

https://github.com/spadgett/console/blob/e07343fd3e7e11a910c54ddd8808bed1207d2ae8/frontend/public/components/monitoring/_monitoring.scss#L46-L53

--- Additional comment from Steve Goodwin on 2020-02-18 20:40:18 UTC ---

Upstream fix in https://github.com/patternfly/patternfly-next/releases/tag/v2.60.0

Comment 1 Steve Goodwin 2020-05-08 17:15:08 UTC
taking a look

Comment 2 bpeterse 2020-05-15 20:17:17 UTC
Bumping to 4.6 as this would not block 4.5.
We may still address early.

Comment 5 XiaochuanWang 2020-05-19 03:11:39 UTC
Created attachment 1689735 [details]
Verification screenshot

Comment 6 XiaochuanWang 2020-05-19 03:12:42 UTC
Now the column header text are divided clearly.
Attached the screenshot for refer.
Verified on 4.5.0-0.nightly-2020-05-19-011623

Comment 8 errata-xmlrpc 2020-07-13 17:24:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.