Bug 181876 - Crash in openoffice.org writer with accessibilty and G_DEBUG=fatal_criticals
Crash in openoffice.org writer with accessibilty and G_DEBUG=fatal_criticals
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 181971 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-17 07:39 EST by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-17 09:04:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 47890 None None None Never

  None (edit)
Description Kjartan Maraas 2006-02-17 07:39:51 EST
Description of problem:

The app crashed first when opening the file menu and another time while I was
not looking.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Output from the app:

Video Driver is probably radeon
Desktop is: GNOME
libgcj version is libgcj-4.1.0-0.27
OpenOffice.org core rpm version is openoffice.org-core-2.0.1.1-11.2.2
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 20
Policy from config file:        targeted
...end sestatus details ...
0x6337688: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e688
0x6337ec8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1eec8
0xf03420:  + 0x420 (__kernel_sigreturn + 0x0)
0xa88c89: /usr/lib/libglib-2.0.so.0 + 0x2dc89 (g_log + 0x29)
0xa88d6b: /usr/lib/libglib-2.0.so.0 + 0x2dd6b (g_return_if_fail_warning + 0x5b)
0xddc5c3: /usr/lib/libatk-1.0.so.0 + 0xa5c3 (atk_object_get_role + 0x73)
0xeca4f7: /usr/lib/gtk-2.0/modules/libgail.so + 0x384f7
0xb17f41: /usr/lib/libgobject-2.0.so.0 + 0x1af41
0xb19623: /usr/lib/libgobject-2.0.so.0 + 0x1c623 (g_signal_emit_valist + 0x823)
0xb198c9: /usr/lib/libgobject-2.0.so.0 + 0x1c8c9 (g_signal_emit + 0x29)
0x315698: /usr/lib/libgtk-x11-2.0.so.0 + 0x214698 (gtk_widget_show + 0x58)
0xe25913: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x29913
0x6832be2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1c3be2
(Window::Show(unsigned char, unsigned short) + 0x476)
0x6832b6d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1c3b6d
(Window::Show(unsigned char, unsigned short) + 0x401)
0x67f546d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18646d
(FloatingWindow::StartPopupMode(Rectangle const&, unsigned long) + 0x20b)
0x67fcb8d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18db8d
0x67fcf23: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18df23
0x67fd4d5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18e4d5
0x67fd67e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18e67e
0x683e973: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cf973
0x68403af: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d13af
0xe2604a: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x2a04a
0xe2429c: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x2829c
0xe24599: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x28599
0x22463e: /usr/lib/libgtk-x11-2.0.so.0 + 0x12363e
0xb05f9d: /usr/lib/libgobject-2.0.so.0 + 0x8f9d (g_closure_invoke + 0x11d)
0xb181c5: /usr/lib/libgobject-2.0.so.0 + 0x1b1c5
0xb194d6: /usr/lib/libgobject-2.0.so.0 + 0x1c4d6 (g_signal_emit_valist + 0x6d6)
0xb198c9: /usr/lib/libgobject-2.0.so.0 + 0x1c8c9 (g_signal_emit + 0x29)
0x30f208: /usr/lib/libgtk-x11-2.0.so.0 + 0x20e208
0x21e08a: /usr/lib/libgtk-x11-2.0.so.0 + 0x11d08a (gtk_propagate_event + 0x1ba)
0x21f2a7: /usr/lib/libgtk-x11-2.0.so.0 + 0x11e2a7 (gtk_main_do_event + 0x317)
0xd7b8aa: /usr/lib/libgdk-x11-2.0.so.0 + 0x408aa
0xa8011d: /usr/lib/libglib-2.0.so.0 + 0x2511d (g_main_context_dispatch + 0x16d)
0xa833af: /usr/lib/libglib-2.0.so.0 + 0x283af
0xa83915: /usr/lib/libglib-2.0.so.0 + 0x28915 (g_main_context_iteration + 0x65)
0xe16889: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1a889
0xe78c4d: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x44c4d
(X11SalInstance::Yield(unsigned char) + 0x27)
0x66f91b2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a1b2
(Application::Yield() + 0x48)
0x66f9236: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a236
(Application::Execute() + 0x26)
0x7fc6e5a: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x27e5a
(desktop::Desktop::Main() + 0x159e)
0x66fd35a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e35a
0x66fd40d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e40d (SVMain()
+ 0x2b)
0x7fbf9a3: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x209a3 (sal_main
+ 0x57)
0x7fbf9ef: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x209ef (main + 0x27)
0x6847a4: /lib/libc.so.6 + 0x157a4 (__libc_start_main + 0xdc)
0x80484d1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4d1

Expected results:


Additional info:
Comment 1 Caolan McNamara 2006-02-17 07:54:41 EST
looks like accessibilty is enabled, is this correct ? 
i.e. what is the output of gconftool-2 -g "/desktop/gnome/interface/accessibility" ?

if it is set to "true", this might be due to gtk being compiled at one stage to
make gtk warnings enforce a crash
Comment 2 Kjartan Maraas 2006-02-17 08:46:27 EST
You are correct in that assessment. I'm still running with
G_DEBUG=fatal_criticals to try and weed out any remaining issues with those. In
most cases they have turned out to be real bugs that needs fixing :-)

I'll install the debuginfo package to see if I can get more data to pinpoint the
exact problem.
Comment 3 Caolan McNamara 2006-02-17 09:04:27 EST
ah, fair enough. Now here's the story...

OOo *normal* accessibility support is a java thing, but that doesn't work with
gcj, so we have to use an experimental atk support patch instead
(workspace.atkbridge.patch in the OOo src.rpm which isn't completely finished yet)

So what I propose is that I update this patch to the latest and greatest
available from OOo cvs and rebuild for rawhide, then you can debug this baby if
it persists and if you still wish to get involved with it. A good place to feed
results back to might be http://qa.openoffice.org/issues/show_bug.cgi?id=47890

I'll set this particular bug as closed->upstream
Comment 4 Caolan McNamara 2006-02-22 04:01:38 EST
*** Bug 181971 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.