Bug 18189 - Anaconda install error (Still not fixed from version 6...)
Anaconda install error (Still not fixed from version 6...)
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 02:59 EDT by derek
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 18:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description derek 2000-10-03 02:59:20 EDT
Probably the buggiest install script ever written.  Rarely works correctly
since Redhat 6.		

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py",
line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43,
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in
__getitem__
KeyError: fileutils

Local variables in innermost frame:
self: <comps.HeaderList instance at 828d180>
item: fileutils

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'ext2'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>
Comment 1 Michael Fulbright 2000-10-03 14:57:55 EDT
This is most likely because of an error in the fileutils RPM in the hard drive
install image.

Please check that the fileutils RPM is intact, and present.

If so, please run the md5sum command on the file and I will check it is ok.
Comment 2 James L. Stadelmann 2000-10-04 21:15:32 EDT
Reopened reportedly 'resolved' bug18136 - with checksig & md5sum info for
openssl.
Comment 3 Need Real Name 2000-10-05 07:45:26 EDT
I tried to install the RH7. I have RH6.2 and I attemtped it to RH7.
I boot from floppy and select the FTP upgrade. Then the anaconda wrote to
console
"...anaconda... terminated with signal 12.
...Reboot system."
The machine was a iPI200MMX/16MB EDO RAM.

I tried the installation on an "AMD K6-III/128MB SDRAM" from ATAPI CDROM. The
installation (upgrade) worked correctly.
Comment 4 Michael Fulbright 2000-10-05 18:11:13 EDT
This occurs when there is something corrupt about the downloaded hard drive
image. We've done numerous hard drive installs w/o seeing these issues.

*** This bug has been marked as a duplicate of 18019 ***
Comment 5 derek 2000-10-05 19:39:22 EDT
From looking at usenet, I know that anaconda errors of this nature have been
widespread and frustrating to many people.  If the root cause is simply a bad
image, though, then the fix is easy - just try downloading it again.  That
worked for me, finally.

Note You need to log in before you can comment on or make changes to this bug.