Bug 1819308 - FailingOperator Alert present after CSV is successfully redeployed
Summary: FailingOperator Alert present after CSV is successfully redeployed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Harish Govindarajulu
QA Contact: Bruno Andrade
URL:
Whiteboard:
: 1834370 (view as bug list)
Depends On:
Blocks: 1843678
TreeView+ depends on / blocked
 
Reported: 2020-03-31 16:29 UTC by Alexander Greene
Modified: 2020-07-13 17:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:24:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1525 0 None closed Bug 1819308: Deleting a CSV removes related CSV metrics 2020-12-06 03:56:37 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:24:49 UTC

Description Alexander Greene 2020-03-31 16:29:54 UTC
Description of problem:
After installing an operator who's deployment failed (via a custom catalog) a FailedOperator alert was created on cluster. 

To fix the failing Operator, I uninstalled the operator, updated the catalog with new image pull specs, and reinstalled the operator. These steps led to a successful deployment of the operator.

Unfortunately, the cluster still has the FailingOperator alert after 24 hours.

Version-Release number of selected component (if applicable):
4.4.0-rc.4

How reproducible:
At least once, should be investigated as a part of this ticket.

Steps to Reproduce:
1. Create a CSV that fails to install
2. Check that the FailingOperator alert is present
3. Delete the failing CSV
4. Update the CSV so it succeeds
5. Inspect the Alerts on the cluster.

Actual results:
FailingOperator alert is present.

Expected results:
FailingOperator alert is removed.


Additional info:

Comment 2 Evan Cordell 2020-05-18 21:51:06 UTC
*** Bug 1834370 has been marked as a duplicate of this bug. ***

Comment 5 Bruno Andrade 2020-05-22 06:13:41 UTC
Alerts were removed after the Operator issue was fixed. Marking as VERIFIED.

OCP Version: 4.4.0-0.nightly-2020-05-21-042450

Comment 7 errata-xmlrpc 2020-07-13 17:24:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.