Bug 1843678 - FailingOperator Alert present after CSV is successfully redeployed
Summary: FailingOperator Alert present after CSV is successfully redeployed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Harish Govindarajulu
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On: 1819308
Blocks: 1843703
TreeView+ depends on / blocked
 
Reported: 2020-06-03 19:51 UTC by Harish Govindarajulu
Modified: 2020-06-29 15:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-29 15:33:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1568 None closed Bug 1843678: Deleting a CSV removes related CSV metrics 2020-09-10 21:13:48 UTC
Red Hat Product Errata RHBA-2020:2713 None None None 2020-06-29 15:34:11 UTC

Description Harish Govindarajulu 2020-06-03 19:51:53 UTC
This bug was initially created as a copy of Bug #1819308

I am copying this bug because: 



Description of problem:
After installing an operator who's deployment failed (via a custom catalog) a FailedOperator alert was created on cluster. 

To fix the failing Operator, I uninstalled the operator, updated the catalog with new image pull specs, and reinstalled the operator. These steps led to a successful deployment of the operator.

Unfortunately, the cluster still has the FailingOperator alert after 24 hours.

Version-Release number of selected component (if applicable):
4.4.0-rc.4

How reproducible:
At least once, should be investigated as a part of this ticket.

Steps to Reproduce:
1. Create a CSV that fails to install
2. Check that the FailingOperator alert is present
3. Delete the failing CSV
4. Update the CSV so it succeeds
5. Inspect the Alerts on the cluster.

Actual results:
FailingOperator alert is present.

Expected results:
FailingOperator alert is removed.


Additional info:

Comment 5 Bruno Andrade 2020-06-22 18:04:12 UTC
Alerts were removed after the Operator issue was fixed. Marking as VERIFIED.

OCP Version: 4.5.0-0.nightly-2020-06-20-194346

Comment 7 errata-xmlrpc 2020-06-29 15:33:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2713


Note You need to log in before you can comment on or make changes to this bug.