Bug 1819603 - Searches for BucketClass in all the namespaces
Summary: Searches for BucketClass in all the namespaces
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.3.z
Assignee: Bipul Adhikari
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On: 1808943
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-01 07:22 UTC by Bipul Adhikari
Modified: 2020-05-12 11:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1808943
Environment:
Last Closed: 2020-05-12 11:44:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4593 None closed [release-4.3] Bug 1819603: Limits Bucket Class search to storage namespace in OBC creation page 2020-05-12 11:43:46 UTC
Github openshift console pull 4869 None closed Bug 1819603: Limit Bucket Class search to storage namespace in OBC creation page 2020-05-12 11:43:46 UTC

Description Bipul Adhikari 2020-04-01 07:22:21 UTC
+++ This bug was initially created as a clone of Bug #1808943 +++

+++ This bug was initially created as a clone of Bug #1806286 +++

Description of problem:
Currently, OB/C bucket class selection searches for bucketclasses in all the namespaces in 4.5. This needs to be limited to only 'openshift-storage' namespace. The reason being bucket classes being created in other namespaces is probably being used for some other purpose than for creating Bucket Claims(Ex: migration).
The fix needs to be backported to all the versions that have OBC features.


Version-Release number of selected component (if applicable):4.5


How reproducible:1/1


Steps to Reproduce:
1. Go to OBC Creation Page.
2. Look at the bucket class selection dropdown. 
3. This will show bucket classes from all the namespaces.

Actual results: Shows bucket classes from all the namespaces.


Expected results: Should show OBC only from 'openshift-storage' namespaces.

--- Additional comment from errata-xmlrpc on 2020-02-28 05:13:33 UTC ---

This bug has been added to advisory RHBA-2020:51809 by OpenShift Release Team Bot (ocp-build/buildvm.openshift.eng.bos.redhat.com@REDHAT.COM)

--- Additional comment from errata-xmlrpc on 2020-02-28 05:13:35 UTC ---

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2020:51809-01
https://errata.devel.redhat.com/advisory/51809

--- Additional comment from errata-xmlrpc on 2020-03-03 00:34:50 UTC ---

This bug has been added to advisory RHBA-2020:0581 by OpenShift Release Team Bot (ocp-build/buildvm.openshift.eng.bos.redhat.com@REDHAT.COM)

--- Additional comment from errata-xmlrpc on 2020-03-03 00:34:53 UTC ---

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2020:0581-01
https://errata.devel.redhat.com/advisory/47983

--- Additional comment from Elena Bondarenko on 2020-03-17 07:58:31 UTC ---

I verified https://bugzilla.redhat.com/show_bug.cgi?id=1806286 today, so it will take some time for the changes to be backported to 4.4. In 4.4.0-0.nightly-2020-03-16-124852 they are not there yet. I'll check again in a few days.

--- Additional comment from Elena Bondarenko on 2020-03-23 11:59:27 UTC ---

I tried with 4.4.0-0.nightly-2020-03-23-010639. The obc bucketclass selection only searches in openshift-storage namespace.


Note You need to log in before you can comment on or make changes to this bug.