Bug 1819938 - OperatorHub doesn't show up after created a ClusterRoleBinding to `aggregate-olm-view` for non-cluster admin users
Summary: OperatorHub doesn't show up after created a ClusterRoleBinding to `aggregate-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1819940
TreeView+ depends on / blocked
 
Reported: 2020-04-01 21:09 UTC by tony.wu
Modified: 2020-07-13 17:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, OperatorHub would only show up for cluster-admin users in the OpenShift console. The bug has been fixed, and OperatorHub will now appear for users who have cluster role bindings `aggregate-olm-view` and `aggregate-olm-edit` assigned.
Clone Of:
: 1819940 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:24:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4883 None closed Bug 1819938: Fix PackageManifest access review 2020-06-23 09:45:04 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:25:09 UTC

Description tony.wu 2020-04-01 21:09:17 UTC
Description of problem:
OperatorHub view in console is depending on if the users have the permission to list package manifests and operator groups in all namespaces. 

However, after created a ClusterRoleBinding to `aggregate-olm-view` for non-cluster admin users, the OperatorHub still doesn't show up.

Version-Release number of selected component (if applicable):
OCP 4.4

How reproducible:
100%

Steps to Reproduce:
1. Create ClusterRoleBinding and bind to a non cluster admin user
2. Log in with that user


Actual results:
Didn't see OperatorHub view

Expected results:
OperatorHub view shows up.

Additional info:

Comment 3 shahan 2020-04-03 03:11:47 UTC
kind: ClusterRoleBinding
apiVersion: rbac.authorization.k8s.io/v1
metadata:
  name: normaluser-olm
subjects:
  - kind: User
    apiGroup: rbac.authorization.k8s.io
    name: testuser-19
roleRef:
  apiGroup: rbac.authorization.k8s.io
  kind: ClusterRole
  name: aggregate-olm-view
create rolebinding to normal user, and The user can view the operator hub page
4.5.0-0.ci-2020-04-03-014149

Comment 5 errata-xmlrpc 2020-07-13 17:24:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.