Bug 1819940 - OperatorHub doesn't show up after created a ClusterRoleBinding to `aggregate-olm-view` for non-cluster admin users
Summary: OperatorHub doesn't show up after created a ClusterRoleBinding to `aggregate-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1819938
Blocks: 1819941
TreeView+ depends on / blocked
 
Reported: 2020-04-01 21:11 UTC by Samuel Padgett
Modified: 2020-05-04 11:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, OperatorHub would only show up for cluster-admin users in the OpenShift console. The bug has been fixed, and OperatorHub will now appear for users who have cluster role bindings `aggregate-olm-view` and `aggregate-olm-edit` assigned.
Clone Of: 1819938
: 1819941 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:47:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4901 None closed Bug 1819940: Fix PackageManifest access review 2020-05-22 13:32:26 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:48:12 UTC

Description Samuel Padgett 2020-04-01 21:11:55 UTC
+++ This bug was initially created as a clone of Bug #1819938 +++

Description of problem:
OperatorHub view in console is depending on if the users have the permission to list package manifests and operator groups in all namespaces. 

However, after created a ClusterRoleBinding to `aggregate-olm-view` for non-cluster admin users, the OperatorHub still doesn't show up.

Version-Release number of selected component (if applicable):
OCP 4.4

How reproducible:
100%

Steps to Reproduce:
1. Create ClusterRoleBinding and bind to a non cluster admin user
2. Log in with that user


Actual results:
Didn't see OperatorHub view

Expected results:
OperatorHub view shows up.

Additional info:

Comment 3 XiaochuanWang 2020-04-07 02:40:39 UTC
After grant the role 'aggregate-olm-view' to a non-cluster-admin user, the user can visit OperatorHub page and see the items.
Verified on 4.4.0-0.nightly-2020-04-04-025830

Comment 5 errata-xmlrpc 2020-05-04 11:47:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.