Bug 182000 - pm-suspend fails in runlevel 1
pm-suspend fails in runlevel 1
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nigel Cunningham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-18 13:31 EST by Need Real Name
Modified: 2008-06-16 21:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:11:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-02-18 13:31:55 EST
Running suspend from Gnome does not work.

If I switch to runlevel 1, and run pm-suspend, the computer appears to suspend.
Unfortunately, it is now dead. Moving the mouse or pressing a button on the
keyboard does nothing. Pushing the button on the front of the pc makes it try
and wake up, but nothing ever happens.

Unfortunately I have no serial cable available to get any debugging information
-  anything I can try?

# uname -rv
2.6.15-1.1955_FC5smp #1 SMP Wed Feb 15 16:01:54 EST 2006

# lspci
00:00.0 Host bridge: ATI Technologies Inc Radeon 9100 IGP Host Bridge (rev 02)
00:01.0 PCI bridge: ATI Technologies Inc Radeon 9100 IGP AGP Bridge
00:13.0 USB Controller: ATI Technologies Inc OHCI USB Controller #1 (rev 01)
00:13.1 USB Controller: ATI Technologies Inc OHCI USB Controller #2 (rev 01)
00:13.2 USB Controller: ATI Technologies Inc EHCI USB Controller (rev 01)
00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 18)
00:14.1 IDE interface: ATI Technologies Inc ATI Dual Channel Bus Master PCI IDE
Controller
00:14.3 ISA bridge: ATI Technologies Inc Unknown device 434c
00:14.4 PCI bridge: ATI Technologies Inc Unknown device 4342
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio
Controller
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon 9100 IGP
02:08.0 Ethernet controller: 3Com Corporation 3Com 3C920B-EMB-WNM Integrated
Fast Ethernet Controller (rev 40)
02:0a.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 80)
02:0c.0 CardBus bridge: ENE Technology Inc CB-710/2/4 Cardbus Controller (rev 02)
02:0c.1 FLASH memory: ENE Technology Inc CB710 Memory Card Reader Controller
Comment 1 Dave Jones 2006-03-02 03:06:23 EST
can you retry with the latest pm-utils & kernel, we've fixed a bunch of stuff
here in the last few days.
Comment 2 Need Real Name 2006-03-03 02:20:11 EST
It's still not working.
Comment 3 Need Real Name 2006-03-03 02:28:34 EST
Attachment 110116 [details] has some hardware info, let me know what else you want.
Comment 4 Jeremy Katz 2006-03-06 11:40:10 EST
If you bring up the network, can you log in remotely once you've resumed with
the power button (it's highly likely that, eg, keys won't wake it up as ACPI is
a little braindead about what wake up events are allowed by default -- that's an
area that we're going to have spend some time looking at a little more post-FC5)
Comment 5 Need Real Name 2006-03-06 11:50:54 EST
I can't test the network part until at least tomorrow - so I tried something else.

A bash loop writes a file every five seconds, the I ran pm-suspend, waited a
bit, then tried to resume. No files after the resume (and the noise from the fan
agrees that it didn't work too - loud).
Comment 6 Dave Jones 2006-10-16 16:18:51 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 7 Need Real Name 2006-10-16 16:48:02 EDT
(In reply to comment #4)
> If you bring up the network, can you log in remotely once you've resumed with
> the power button (it's highly likely that, eg, keys won't wake it up as ACPI is
> a little braindead about what wake up events are allowed by default -- that's an
> area that we're going to have spend some time looking at a little more post-FC5)

Haven't tried the network thing. Will do. Still broken though.

kernel-2.6.18-1.2784.fc6
Comment 8 Need Real Name 2007-06-28 16:30:17 EDT
> Haven't tried the network thing. Will do. Still broken though.

I don't have a spare computer to try the network thing with.
Is there another way to diagnose this?
Comment 9 Nigel Cunningham 2007-06-28 22:10:14 EDT
Could you please try testing the different possibilities for quirks for your 
computer? One or more might be needed to get the video back. If you can get 
video, that will be a good start. Here is a link that should help:

http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html

Reassigning to me.
Comment 10 Need Real Name 2007-07-04 17:35:44 EDT
I followed the instructions. First some feedback on those.

There is obviously a lot of information on there, but the front page is confusing.
I want to troubleshoot resume failing. There is no really obvious choice.
After clicking a few options, I realise that "I want to check common problems
and to find quirks to try" is the option to choose, although I don't want to
check common problems or find quirks to try, I want to find out why my hardware
isn't resuming. "quirks" are things I want to avoid :)

Anyway.

Trying the dmesg/rtc thing, I get the following:
  hash matches drivers/base/power/resume.c:70
  hash matches device serial8250
lsmod|grep ser shows the device serio_raw, so I tried rmmod serio_raw and
pm-suspend, but that didn't help.

Maybe if I described the boot process a bit more, that would help.
After I type pm-suspend the computer almost shuts down - everything as a normal
poweroff, but with a flashing power light. I push the power button and the
following happens:
1. The hard disk spins up
2. Just two of the keyboard lights keep flashing (rather than all three lighting
at once and just once). The lights are numlock and scroll lock.
3. Nothing else. Display is in power saving mode.

I'll try -quirk-dpms-on next, then I'll try the kernel options.
Comment 11 Need Real Name 2007-07-04 17:46:06 EDT
--quirk-dpms-on didn't help.

I tried the first two kernel options:
maxcpus=1
vga=normal

These didn't help either. I'll try the others when I have time.

At boot the kernel says:
 BUG: 8252 timer not connected to IO-APIC.
Is this relevant?
Comment 12 Nigel Cunningham 2007-07-05 20:47:39 EDT
Thanks for giving this a go. Re comment 10, I'd note the following things:

There might be more than one issue. I'd continue to remove serial port support 
while trying to suspend, since it has had problems. (They should be fixed in 
more recent vanilla kernels, IIRC). You might try adding i8042.reset=1 to the 
commandline this helps on my laptop (different brand though).

The keyboard lights flashing is good. It means you're getting at least some 
progress in resuming from the suspend to ram. You might try also adding 
acpi_sleep=s3_bios,s3_mode to your boot command line. Note that the order is 
important - a bug has just been discovered in which putting s3_bios first is 
necessary (it undoes any s3_mode that comes beforehand). Adding this will make 
the wakeup code try to reinitialise the video as one of the first things; it 
might get you your display back. You should then be able to see the cause of 
the oops that's making those lights flash.

Re the timer not being connected, I'm not completely sure, but don't think it 
should be relevant. 8252, or 8250?
Comment 13 Nigel Cunningham 2007-12-10 17:20:09 EST
Any progress here?
Comment 14 Bug Zapper 2008-05-14 07:59:02 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2008-06-16 21:11:17 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.