Bug 1820274 - Conformance: "should set Forwarded headers appropriately" router test fails on OVN
Summary: Conformance: "should set Forwarded headers appropriately" router test fails o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.4.z
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On: 1836509
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-02 16:11 UTC by Daneyon Hansen
Modified: 2020-06-17 22:26 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1802311
Environment:
Last Closed: 2020-06-17 22:26:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24823 None closed [release-4.4] Bug 1820274: e2e: Disable router header test on OVN 2020-06-08 02:17:16 UTC
Red Hat Product Errata RHBA-2020:2445 None None None 2020-06-17 22:26:28 UTC

Comment 1 Daneyon Hansen 2020-04-02 16:20:45 UTC
PR to disable the failing test: https://github.com/openshift/origin/pull/24823

Comment 2 Dan Mace 2020-04-13 12:22:15 UTC
This is blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1812960 (via https://bugzilla.redhat.com/show_bug.cgi?id=1802311). The issue is something to do with OVN.

Comment 3 Ben Parees 2020-04-13 13:28:20 UTC
azure+gcp OVN jobs have been marked "broken":
https://github.com/openshift/release/pull/8197


tracking bugs to re-enable them:
https://bugzilla.redhat.com/show_bug.cgi?id=1821866
https://bugzilla.redhat.com/show_bug.cgi?id=1821867

they will likely not be re-enabled in 4.4, so if you're sure this bug only occurs on azure+gcp OVN environments, i think you can safely defer it to 4.5 as well.

Comment 4 Dan Mace 2020-04-13 13:34:16 UTC
We already have a 4.5 bug (https://bugzilla.redhat.com/show_bug.cgi?id=1802311), so should this 4.4 bug simply be closed as WONTFIX?

Comment 5 Ben Parees 2020-04-13 13:37:59 UTC
Please confirm w/ the SDN team that they have no intent to ship support for OVN on GCP+Azure in 4.4 and you can close this as won't fix.

Comment 6 Dan Mace 2020-04-13 13:46:09 UTC
Confirmed with Dan Winship that we won't block 4.4 on a fix here. If the 4.5 fix is able to be backported, we can revisit.

Comment 7 Dan Winship 2020-05-16 13:09:09 UTC
reopening to backport disabling the failing test

Comment 11 errata-xmlrpc 2020-06-17 22:26:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2445


Note You need to log in before you can comment on or make changes to this bug.