Bug 1820731 - [4.4] Marketplace diff name test create the samename opsrc&csc
Summary: [4.4] Marketplace diff name test create the samename opsrc&csc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: All
OS: All
high
high
Target Milestone: ---
: 4.4.z
Assignee: odin team (olm)
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On: 1836719
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-03 17:43 UTC by Sebastian Jug
Modified: 2020-07-14 01:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1836719 (view as bug list)
Environment:
Last Closed: 2020-07-14 01:43:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-tests pull 30 None closed Bug 1820731: samename test flake fix 2020-07-09 03:36:19 UTC
Github openshift origin pull 24986 None closed Bug 1820731: samename test flake fix 2020-07-09 03:36:18 UTC
Red Hat Product Errata RHBA-2020:2871 None None None 2020-07-14 01:44:15 UTC

Description Sebastian Jug 2020-04-03 17:43:47 UTC
Description of problem:
Able to create CSV of same name

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-04-03-093209
4.4.0-0.nightly-2020-04-03-072527

How reproducible:
Sometimes

Steps to Reproduce:
1. Check release-openshift-ocp-installer-e2e-gcp-ovn-4.4 runs
2. Look for "Marketplace diff name test"
3. Find test results

Actual results:
[Feature:Marketplace] Marketplace diff name test [Top Level] [Feature:Marketplace] Marketplace diff name test [ocp-25672] create the samename opsrc&csc [Suite:openshift/conformance/parallel] expand_less 	36s
fail [github.com/openshift/origin/test/extended/marketplace/marketplace_diffname.go:84]: Expected
    <string>: 
to contain substring
    <string>: Deployment samename exists

Expected results:
Expected to see "Deployment samename exists"


Additional info:

Comment 2 Ben Parees 2020-04-13 19:59:46 UTC
this is failing 15% of the time it runs, raising severity and please backport any fix to 4.4 so we can have clean runs there as well.

Comment 3 lgallett 2020-04-14 16:17:48 UTC
This seems to be an issue with the test asking too quickly - a suggested fix https://github.com/openshift/openshift-tests/pull/30

Comment 4 Evan Cordell 2020-05-07 17:16:55 UTC
https://github.com/openshift/openshift-tests/pull/30 is merged, and I don't see the original test as a flake on the gcp-ovn 4.4 suite.

Comment 7 W. Trevor King 2020-05-08 03:58:51 UTC
This bug is ON_QA despite linking [1] (which is in need of a rebase and hasn't been touched in 2 weeks), but it still fails in 3% of 4.4 release jobs [2].  Does [1] need to get revived or something?

[1]: https://github.com/openshift/origin/pull/24871
[2]: https://search.apps.build01.ci.devcluster.openshift.com/chart?name=release-openshift-ocp.*4.4&search=failed:.*Marketplace%20diff%20name%20test.*create%20the%20samename%20opsrc&maxAge=24h

Comment 9 Fan Jia 2020-05-15 09:01:26 UTC
The fix for origin :https://github.com/openshift/origin/pull/24986

Comment 15 errata-xmlrpc 2020-07-14 01:43:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2871


Note You need to log in before you can comment on or make changes to this bug.