Bug 182091 - Exim wont start - wrong user-group-permissions on log directory
Exim wont start - wrong user-group-permissions on log directory
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distcache (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
: 183460 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 08:25 EST by jason meers
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.4.5-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-29 07:28:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jason meers 2006-02-20 08:25:55 EST
Description of problem:
Exim wont start - wrong user-group-permissions on log directory
exim tries to start under euid=93 and egid=93 which is not the correct user
account and does not have permissions in the /var/log/exim/ dir.

a chmod 777 /var/log/exim/ will fix the error, proving the problem

Version-Release number of selected component (if applicable):
the 4.60 version installed from yum -y install exim* on FC5-test2

How reproducible:
service exim restart after (using system-switch-mail utility)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I'm happy to work with you on this, I have lots of exim boxes at work and a few
FC5-test boxes at home
Comment 1 David Woodhouse 2006-02-20 08:39:50 EST
Why isn't 93 the correct user ID? It should be reserved for the Exim user.
Comment 2 jason meers 2006-02-20 08:54:32 EST
I dont have an exim user on my system. User 93 and group 93 belong to the
"distcache" user and group. I dont recognize these, maybe thats why the exim
user never got created when I added the package.

# more /etc/passwd | grep 93
distcache:x:93:93:Distcache:/:/sbin/nologin

# more /etc/group | grep 93
distcache:x:93:


Comment 3 David Woodhouse 2006-02-20 09:00:46 EST
The 'distcache' package in Fedora doesn't seem to create such a user. Where did
it come from?
Comment 4 jason meers 2006-02-20 09:17:39 EST
removed distcache package (which also removed mod_ssl)
removed exim packages
deleted distcache user and group
installed exim packages again and exim now starts
uid and gid now correct

# more /etc/passwd | grep 93
exim:x:93:93::/var/spool/exim:/sbin/nologin

# more /etc/group | grep 93
exim:x:93:

I must have installed distcache a part of the webserver packages during the
original install. I have been running a nightly yum update since the install of
test2 but only came to use exim last night.
Comment 5 jason meers 2006-02-26 15:59:00 EST
completely new and clean installation of FC5 Test3.
Distcache user and group still in uid 93 and gid 93 preventing the exim user and
group using it.

Below is the output from yum when trying to install exim almost imeadiately
after "firstboot" config had been completed. The only other update I did before
this was "yum -y install gconf*" (to fix the crappy nautilus defaults)

yum -y install exim
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
extras-dev: ################################################## 2/2
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package exim.i386 0:4.60-2.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libmysqlclient.so.15 for package: exim
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package mysql.i386 0:5.0.18-2.1 set to be updated
--> Running transaction check
--> Processing Dependency: perl(DBI) for package: mysql
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-DBI.i386 0:1.50-2.2 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 exim                    i386       4.60-2.fc5       extras-development  1.2 M
Installing for dependencies:
 mysql                   i386       5.0.18-2.1       development       2.9 M
 perl-DBI                i386       1.50-2.2         development       581 k

Transaction Summary
=============================================================================
Install      3 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 4.6 M
Downloading Packages:
(1/3): exim-4.60-2.fc5.i3 100% |=========================| 1.2 MB    00:03
(2/3): perl-DBI-1.50-2.2. 100% |=========================| 581 kB    00:01
(3/3): mysql-5.0.18-2.1.i 100% |=========================| 2.9 MB    00:08
Running Transaction Test
warning: perl-DBI-1.50-2.2: Header V3 DSA signature: NOKEY, key ID 30c9ecf8
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: perl-DBI                     ######################### [1/3]
  Installing: mysql                        ######################### [2/3]
  Installing: exim                         ######################## 
[3/3]warning: user exim does not exist - using root
warning: group exim does not exist - using root
  Installing: exim                         ######################## 
[3/3]warning: user exim does not exist - using root
warning: group exim does not exist - using root
  Installing: exim                         ######################## 
[3/3]warning: user exim does not exist - using root
warning: group exim does not exist - using root
  Installing: exim                         ######################## 
[3/3]warning: user exim does not exist - using root
warning: group exim does not exist - using root
  Installing: exim                         ######################## 
[3/3]warning: user exim does not exist - using root
warning: group exim does not exist - using root
  Installing: exim                         ######################### [3/3]
chown: `exim.exim': invalid user

Installed: exim.i386 0:4.60-2.fc5
Dependency Installed: mysql.i386 0:5.0.18-2.1 perl-DBI.i386 0:1.50-2.2
Complete!
-----
I then tried to start exim (in foreground to see debug output)

exim -bdf
2006-02-26 21:01:52 Cannot open main log file "/var/log/exim/main.log":
Permission denied: euid=93 egid=93
2006-02-26 21:01:52 exim 4.60 daemon started: pid=3457, no queue runs, listening
for SMTP on port 25 (IPv6 with IPv4)
2006-02-26 21:01:52 Cannot open main log file "/var/log/exim/main.log":
Permission denied: euid=93 egid=93
exim: could not open panic log - aborting: see message(s) above

Thanks

Jason Meers
Comment 6 Axel Thimm 2006-03-01 05:13:17 EST
This is not an exim bug, I just filed a bug against distcache (bug #183460)
before I found this entry (If found it because I wanted to add David to the Cc).

Please reassign this to distcache.
Comment 7 Axel Thimm 2006-03-01 05:14:40 EST
*** Bug 183460 has been marked as a duplicate of this bug. ***
Comment 8 Axel Thimm 2006-03-01 05:15:49 EST
Fedora Core 2, Fedora Core 3 and RHEL4 contain exim which has uid/gid 93.
Currently exim is in Fedora Extras and ATrpms.

Every update from FC2, FC3, FC4 breaks distcache, every FC5 install would break
exim from Fedora Extras and ATrpms.

Since exim has been officially deployed with uid/gid 93 in the past, distcache
should pick another set before FC5 is released.

Comment 9 Joe Orton 2006-03-01 05:24:31 EST
distcache was assigned 93 by Bill, Official Assignerer Of UIDs.  I guess exim
has never had an official uid assignment made.

Bill, can you change the uid/gid 93 assignment to be exim (since it's the more
widely used of the two packages), and assign something new for distcache?
Comment 10 Bill Nottingham 2006-03-01 11:46:23 EST
93 added to the file for exim. distcache can use 94/94.
Comment 11 Joe Orton 2006-03-02 10:45:18 EST
Thanks Bill.

Note You need to log in before you can comment on or make changes to this bug.