Bug 1821345 - Anaconda is no more accessible for the blind under Wayland
Summary: Anaconda is no more accessible for the blind under Wayland
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: at-spi2-core
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1880742 1945423 (view as bug list)
Depends On:
Blocks: F34FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-04-06 15:47 UTC by Bohdan Milar
Modified: 2021-04-23 21:03 UTC (History)
18 users (show)

Fixed In Version: at-spi2-core-2.40.0-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-23 21:03:34 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME at-spi2-core issues 34 0 None None None 2021-04-15 20:06:07 UTC
Red Hat Bugzilla 1592361 0 unspecified CLOSED Custom accessibility role of disk overview breaks the spoken output of Orca 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1818957 0 unspecified NEW Install destination list not accessible for blind users 2021-08-10 12:47:32 UTC

Internal Links: 1818957

Description Bohdan Milar 2020-04-06 15:47:46 UTC
Description of problem:
The problem was noticed while installing Fedora 32 Workstation from live image. Namely in Gnome on Wayland. The environmet itself works fine with Orca screen reader. But from the moment Anaconda is started, Orca stops talking completely. So even if user tries to switch to another application (Alt + Tab etc.), speech does not work.

Version-Release number of selected component (if applicable):
anaconda-32.24.3-1.fc32.x86_64

How reproducible:
always

Steps to Reproduce:
1. Boot the Live Fedora 32 Workstation installation image under Wayland session.
2. Launch Orca with Alt + Super + s (and adjust sound volume).
3. Press Insert + t (or KP_Insert + t) to test whether Orca speaks.
4. Launch Anaconda installer.
5. Press Insert + t (or KP_Insert + t) to test whether Orca speaks.

Actual results:
Orca says nothing and even Orca's other shortcuts (see documentation) not working.

Expected results:
Orca reads the content when navigation keys (tab, shift + tab, up, down, left and right arrows) are used.

Additional info:
The issue was discovered by Pavel Vlček (CC). I reported it, because Bugzilla also has some accessibility issues.

Comment 1 Jiri Konecny 2020-04-07 06:38:44 UTC
Related bug 1818957.

Comment 2 Vladimír Slávik 2020-09-22 12:43:24 UTC
*** Bug 1880742 has been marked as a duplicate of this bug. ***

Comment 3 Vladimír Slávik 2021-01-19 17:37:04 UTC
Related bug 1592361.

Comment 4 Adam Williamson 2021-04-15 19:20:24 UTC
We've been talking about this recently, and benzea thinks he has a way to work around the problem. I'm going to test it in a scratch build shortly. Proposing this as an F34 Final FE: if we can solve it, that would be a substantial a11y improvement and I think worth an FE, obviously cannot be fixed with an update.

Comment 5 Adam Williamson 2021-04-15 19:22:17 UTC
For the record, this is the plan:

benzea: soo
benzea: xprop -root -format AT_SPI_BUS 8s -set 'AT_SPI_BUS' "$( busctl call --user org.a11y.Bus /org/a11y/bus org.a11y.Bus GetAddress | sed 's/s "\(.*\)"/\1/' )"
benzea: single line script installed at /etc/xdg/Xwayland-session.d/00-at-spi
benzea: I hope that would do the trick
benzea: well, pretty sure it'll work, and it feels pretty clean, we could even just install it as part of the at-spi package in general

Comment 6 Adam Williamson 2021-04-16 00:54:02 UTC
So I tested a scratch build of at-spi2-core with the exact change benzea proposed - dropping a script with that contents as /etc/xdg/Xwayland-session.d/00-at-spi - and it works. Built a live image with that build, booted it, turned on orca, ran anaconda, and got screen reading. I'm not sure how navigable anaconda is for people who actually can't see the screen, to be honest, but at least the tech works.

Going to mark as POST, but see exactly how much error checking Benjamin thinks might be needed :)

Comment 7 Benjamin Berg 2021-04-16 08:50:27 UTC
The error checking is not really needed, in particular in Fedora where we can blindly rely on systemd to be installed.

After all, if the dbus call fails, then the a11y infrastructure is probably not functional anyway and setting the X property cannot be destructive.

Comment 8 Adam Williamson 2021-04-17 05:35:42 UTC
okay, I guess I'll send a build just as-is then.

+3 votes in https://pagure.io/fedora-qa/blocker-review/issue/357 , marking accepted FE.

Comment 9 Fedora Update System 2021-04-17 05:56:04 UTC
FEDORA-2021-89f1fdaefd has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-89f1fdaefd

Comment 10 Fedora Update System 2021-04-18 17:04:05 UTC
FEDORA-2021-89f1fdaefd has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-89f1fdaefd`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-89f1fdaefd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Adam Williamson 2021-04-19 23:51:58 UTC
Can folks please test and karma the update? I did test the change myself and it worked fine, but I can't karma my own update. Thanks!

Comment 12 Vladimír Slávik 2021-04-20 11:15:21 UTC
*** Bug 1945423 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2021-04-23 21:03:34 UTC
FEDORA-2021-89f1fdaefd has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.