Bug 182149 - haldaemon userid in ps auxf looks odd.
haldaemon userid in ps auxf looks odd.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Brian Brock
:
: 181998 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 14:56 EST by Dave Jones
Modified: 2015-01-04 17:25 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 16:18:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-02-20 14:56:34 EST
(14:25:42:davej@nwo:~)$ ps aux | grep hal
68        2634  0.0  0.3  15944  3632 ?        Ss   Feb19   0:01 hald
root      2635  0.0  0.1  10320  1048 ?        S    Feb19   0:00 hald-runner
root      2642  0.0  0.0   7308   752 ?        S    Feb19   0:00
/usr/libexec/hald-addon-acpi
68        2648  0.0  0.0   8376   888 ?        S    Feb19   0:00
/usr/libexec/hald-addon-keyboard
root      2661  0.0  0.0   7312   748 ?        S    Feb19   0:00
/usr/libexec/hald-addon-storage
davej    19316  0.0  0.0   3924   600 pts/6    S+   14:27   0:00 grep hal


68 looks funny. Should be 'haldaemon' ?
Comment 1 Matthias Clasen 2006-02-23 14:30:26 EST
The same happens with beagleindex
Comment 2 Matthias Clasen 2006-02-23 14:41:15 EST
Seems to be a stupid length limitation in ps.
Changing dbus to dbuuuuuus makes it disappear from ps aux output too
Comment 3 Karel Zak 2006-02-23 16:18:11 EST
Why do long usernames get printed as numbers?

procps FAQ:

Why do long usernames get printed as numbers?

The UNIX and POSIX standards require that user names and group names be printed
as decimal integers when there is not enough room in the column. Truncating the
names, besides being a violation of the standard, would lead to confusion
between names like MichelleRichards and MichelleRichardson. The UNIX and POSIX
way to change column width is to rename the column:

     ps -o pid,user=CumbersomeUserNames -o comm

The easy way is to directly specify the desired width:

     ps -o pid,user:19,comm


The current width of the USER column is 8 cells (it's probably classic UNIX
username limitation). I think we should use shorter usernames for system accounts. 

Well, we can enlarge the column, but I'm pretty sure that we will see bug
reports from people who run scripts where is expected this size. My experience
is that our uses (and RHEL custumers;-) are really sensitive to 'ps' output.

Please, reopen the bug if you think that the problem should be fixed by procps.
Thanks.
Comment 4 Karel Zak 2006-03-23 08:00:09 EST
*** Bug 181998 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.