Bug 182174 - MIssing Build Requirements in sound-juicer
MIssing Build Requirements in sound-juicer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Monty
: EasyFix, FutureFeature, Patch
: 157140 189406 (view as bug list)
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-02-20 16:24 EST by Brian Pepple
Modified: 2013-10-20 18:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-20 23:59:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch (5.29 KB, patch)
2006-02-20 16:24 EST, Brian Pepple
no flags Details | Diff
Patch, adding the missing buildreqs (929 bytes, patch)
2006-05-16 06:34 EDT, Andreas Thienemann
no flags Details | Diff

  None (edit)
Description Brian Pepple 2006-02-20 16:24:00 EST
Description of problem:
Attempt to rebuild Sound-Juicer, and it should fail due to missing build
requirements.


Version-Release number of selected component (if applicable):
2.13.5-1

Additional info:  In addition to a couple of missing BR, there is a bunch of
packages that aren't needed as BR's.

I'll attach a patch for the spec file that should sort out the build
requirements, and also use some of the packaging practices used in FE.  It
builds fine in Mock now, and rpmlint doesn't spit out any errors.

I also noticed that libcdio is in extras, and it might be worth moving that to
Core for Sound-Juicer (though I'm not familar enough with libcdio to determine
what benefit it provides).
Comment 1 Brian Pepple 2006-02-20 16:24:00 EST
Created attachment 124910 [details]
Spec file patch
Comment 2 Rex Dieter 2006-04-13 15:03:15 EDT
added Patch, EasyFix keywords.

Though, I'd personally be hesitant to apply some of the suggested mods involving
%{name} (esp in %files), since it would break if the pkgname ever changed.
Comment 3 John Thacker 2006-04-14 15:11:05 EDT
*** Bug 157140 has been marked as a duplicate of this bug. ***
Comment 4 John Thacker 2006-04-20 11:48:32 EDT
*** Bug 189406 has been marked as a duplicate of this bug. ***
Comment 5 Andreas Thienemann 2006-05-16 06:30:31 EDT
Added patch, to make sound-juicer compile in mock.
This patch is less intrusive then (id=124910) and fixes only the BuildRequirements.
Comment 6 Andreas Thienemann 2006-05-16 06:34:17 EDT
Created attachment 129168 [details]
Patch, adding the missing buildreqs
Comment 7 Brian Pepple 2006-05-16 09:12:39 EDT
I belive you need to add a Requires for gstreamer-plugins-base, since this won't
be pulled in automatically.
Comment 8 John Thacker 2006-05-19 12:38:48 EDT
The BuildRequires for gstreamer-plugins-base has been added in CVS now.  I
believe that gnome-doc-utils still needs to be added a BR, though.
Comment 9 Matthias Clasen 2006-05-20 23:59:24 EDT
Fixed

Note You need to log in before you can comment on or make changes to this bug.