Bug 182197 - kernel 2.6.15-1830/1831 does not properly initialize usb mouse
kernel 2.6.15-1830/1831 does not properly initialize usb mouse
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-20 17:50 EST by roebel
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.17-1.2187_1.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 04:26:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lsusb -v (9.62 KB, text/plain)
2006-02-20 17:50 EST, roebel
no flags Details
lsusb -v output (13.19 KB, text/plain)
2006-03-06 22:02 EST, Chris Spencer
no flags Details

  None (edit)
Description roebel 2006-02-20 17:50:30 EST
Description of problem:    
    
since I upgraded to 2.6.15-1830 and now 2.6.15-1831    
I have a problem with my usb mouse on one of my laptops     
(samsung M4). When booting with that kernel the mouse is not    
properly initialized and I have to unplug and replug it a number    
of times before it becomes usuable. The funny thing is that   
the usbhid driver detects the mouse and appears to be initialized   
but it does not deliver any mouse events to /dev/input/mice.   
  
The same version of kernel and other components do work with the   
same mouse on another compaq laptop that I have.  
    
Version-Release number of selected component (if applicable):    
   
 kernel 2.6.15-1830/1831, all packages upgraded with   
  
yum update  
    
How reproducible:    
    
boot kernel with usb mouse attached on samsung m4 laptop  
    
Status of lsusb -v for a situation after booting with the mouse not working is 
attached. Note that the lsusb status will not change if after some  
plugging cycles the mouse is working. 
 
It appears that mouse initialization generally succeeds 
if I move the mouse while I plug it back in.
Comment 1 roebel 2006-02-20 17:50:30 EST
Created attachment 124917 [details]
output of lsusb -v
Comment 2 Kari Myllykangas 2006-02-25 04:49:42 EST
The other possibility to get the optical usb mouse to work is to log on (as a
root or usual user). Then the mouse doesnt't work. After that you logout
(Gnome). Then you you are in screen where you can login again. Now the mouse works!

The problem is not only in the usb mouses. 
"So it's NOT just a mouse problem.  It seems to be something in the HID
layer that's not properly handling some USB HID devices (Mouse,
Keyboard, or PS/2 adapters).  And it's NOT a USB port problem.  It's
reproducible and deterministic with certain devices on 2.6.15, but not
all of them."
Ref: https://www.redhat.com/archives/fedora-list/2006-February/msg03505.html
Comment 3 Enrique Gomezdelcampo 2006-03-03 17:29:32 EST
I have a HP zd7000 P4HT laptop running FC4. When I updated it to the latest
kernel (2.6.15-1.1830_FC4smp) my external usb mouse does not work. I can turn
off the integrated touchpad and the usb mouse still is not recognized. I
unplugged it and plug it back again and I get this message (and still does not
work):

kernel: usb 2-1: USB disconnect, address 2
kernel: usb 2-1: new low speed USB device using uhci_hcd and address 3
kernel: input: Agiler 3D USB Mouse as /class/input/input3

kernel: input: USB HID v1.00 Mouse [Agiler 3D USB Mouse] on usb-0000:00:1d.0-1

If I revert to the previous kernel (2.6.14-1.1656_FC4smp) the usb mouse works
fine. So, it is not a udev (071-0.FC4.3) problem.
Comment 4 Enrique Gomezdelcampo 2006-03-03 17:32:18 EST
Same problem with newest kernel (2.6.15-1.1833_FC4smp)
Comment 5 William D. McCoy 2006-03-04 21:16:31 EST
I came to bugzilla to file a bug about the new 2.6.15 kernel and my USB mouse,
but I see that essentially the same bug has been reported.  Perhaps adding info
about my experience will help.

I have an Averatec 3150HW laptop and I experienced the same problem after
ipgrading from kernel 2.6.14-1.1656_FC4 to 2.6.15-1.1831_FC4 (I missed one or
two kernel releases in between) a couple of weeks ago.  Today I upgraded to
kernel 2.6.15-1.1833_FC4 and still have the problem.  The touchpad works fine
regardless of the kernel, but the external Belkin USB 3-button mouse does not
work at all with the 2.6.15 kernels -- even with repeated detaching and
re-attaching.  The USB mouse is apparently recognized as I get the same messages
in /var/log/messages when the mouse is removed and re-attached, regardless of
the kernel (2.6.14 or 2.6.15).  And lsmod shows uhci-hcd and ehci-hcd loaded
regardless of the kernel -- and usbview shows no apparent differences.  But when
I move the mouse, the mouse cursor does not move on the screen and the mouse
buttons have no effect under the 2.6.15 kernels.  So for now I am using the
2.6.14 kernel.
Comment 6 roebel 2006-03-05 11:47:21 EST
Did you try moving the mouse while you (re-)attach it? Funny enough this  
always works for me. Even with software suspend 2 if I resume and move the  
mouse when the X server comes back the mouse is properly working. It  
is not as it should be, but for me it is sufficiently reliable that I  
can now use these kernels.   
Comment 7 William D. McCoy 2006-03-05 13:13:56 EST
Yes, I just tried this and it does work reliably if I move the mouse while I
re-attach it.  It didn't help to move it while I was starting X (from runlevel
3), but if I move it while inserting the USB cable it works every time.  And
then if I detach and re-attach again without moving the mouse, it doesn't work.

Because it is a small laptop, it's rather awkward to attach the mouse while
moving it.  I have to move the mouse with my right hand while holding the laptop
in place with my left elbow and inserting the cable with my left hand!  But it's
good to know that I can use the most recent 2.6.15 kernel (1833) and have the
use of my external mouse.  And maybe this information will help the maintainers
in debugging.

I haven't yet tried any other USB devices.  If I get time this afternoon, I will
try attaching my camera to see if that works ok with the newest kernel.

Thanks for the suggestion.
Comment 8 Chris Spencer 2006-03-06 22:00:30 EST
I've experienced a similar problem. After upgrading to 2.6.15-1.1833, my USB
Logitech mouse is completely inoperable. Unplugging and replugging has no effect. 
Comment 9 Chris Spencer 2006-03-06 22:02:46 EST
Created attachment 125743 [details]
lsusb -v output
Comment 10 Dave Jones 2006-09-16 22:39:08 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 11 Dave Jones 2006-10-16 14:46:31 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 12 roebel 2006-10-30 04:26:18 EST
Hi, 

The problem disappeared during some update to a 
more recent kernel on FC4.

I am using Fedora 5 with kernel 2.6.17-1.2187_1.fc5 now.
there as well the problem is not present.
So all is fine for that version.

Thanks,

Note You need to log in before you can comment on or make changes to this bug.