Bug 1822325 - Unable to start node maintenance from openshift UI
Summary: Unable to start node maintenance from openshift UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.5.0
Assignee: Jiri Tomasek
QA Contact: Udi Kalifon
URL:
Whiteboard:
: 1816969 1819605 (view as bug list)
Depends On:
Blocks: 1819605 1822716
TreeView+ depends on / blocked
 
Reported: 2020-04-08 18:14 UTC by mlammon
Modified: 2020-07-13 17:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1822716 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:26:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5029 0 None closed Bug 1822325: StartMaintenanceModal - Fetch CephCluster resources only when ceph functionality is available 2020-08-18 14:26:23 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:26:47 UTC

Description mlammon 2020-04-08 18:14:19 UTC
Unable to start node maintenance from openshift UI

Version:
4.4.0-0.nightly-2020-04-04-025830

Steps to reproduce:
1. Deploy cluster
2. Install CNV 2.30 (which include node maintenance operator)
3. login to openshift container platform
4. select compute -> Nodes 
5. select 3 dots Start Maintenance

It also don't work under Bare Metal Hosts - > Start Node Maintenance 
I can kick it off from CLI and shows up in GUI

How reproducible:
100%

 

Work around using CLI:

1) create node-maint.yaml and add the following:

apiVersion: kubevirt.io/v1alpha1
kind: NodeMaintenance
metadata:
  name: master-0-0-maintenance
spec:
  nodeName: master-0-0
  reason: "replacing master-0-0"


2) apply config
[root@sealusa6 ~]# oc apply -f node-maint.yaml
nodemaintenance.kubevirt.io/master-0-0-maintenance created


3) check 
[root@sealusa6 ~]# oc get nodemaintenances.kubevirt.io
NAME                     AGE
master-0-0-maintenance   2m56s

4) desc

Expected results:
Expected either pop up or Status changes to Under Maintenance (like seen when start from CLI)

Comment 1 Jiri Tomasek 2020-04-14 10:01:37 UTC
*** Bug 1819605 has been marked as a duplicate of this bug. ***

Comment 4 Jiri Tomasek 2020-04-15 06:45:14 UTC
*** Bug 1816969 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2020-07-13 17:26:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.