Bug 1822716 - Unable to start node maintenance from openshift UI
Summary: Unable to start node maintenance from openshift UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On: 1822325
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-09 17:02 UTC by Samuel Padgett
Modified: 2020-05-04 11:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1822325
Environment:
Last Closed: 2020-05-04 11:49:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5049 None closed [release-4.4] Bug 1822716: Fetch CephCluster resources only when ceph functionality is available 2020-09-08 18:02:10 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:49:51 UTC

Description Samuel Padgett 2020-04-09 17:02:34 UTC
+++ This bug was initially created as a clone of Bug #1822325 +++

Unable to start node maintenance from openshift UI

Version:
4.4.0-0.nightly-2020-04-04-025830

Steps to reproduce:
1. Deploy cluster
2. Install CNV 2.30 (which include node maintenance operator)
3. login to openshift container platform
4. select compute -> Nodes 
5. select 3 dots Start Maintenance

It also don't work under Bare Metal Hosts - > Start Node Maintenance 
I can kick it off from CLI and shows up in GUI

How reproducible:
100%

 

Work around using CLI:

1) create node-maint.yaml and add the following:

apiVersion: kubevirt.io/v1alpha1
kind: NodeMaintenance
metadata:
  name: master-0-0-maintenance
spec:
  nodeName: master-0-0
  reason: "replacing master-0-0"


2) apply config
[root@sealusa6 ~]# oc apply -f node-maint.yaml
nodemaintenance.kubevirt.io/master-0-0-maintenance created


3) check 
[root@sealusa6 ~]# oc get nodemaintenances.kubevirt.io
NAME                     AGE
master-0-0-maintenance   2m56s

4) desc

Expected results:
Expected either pop up or Status changes to Under Maintenance (like seen when start from CLI)

Comment 3 mlammon 2020-04-22 19:01:09 UTC
Verified in UI in 4.4 release

version   4.4.0-0.nightly-2020-04-21-210658   True        False         4h36m   Cluster version is 4.4.0-0.nightly-2020-04-21-210658

Comment 5 errata-xmlrpc 2020-05-04 11:49:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.