Bug 1822326 - The ip check in the etcd-ensure-env-vars init container doesn't work in the ipv6 environments
Summary: The ip check in the etcd-ensure-env-vars init container doesn't work in the i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Suresh Kolichala
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks: 1822327
TreeView+ depends on / blocked
 
Reported: 2020-04-08 18:21 UTC by Suresh Kolichala
Modified: 2020-07-13 17:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The env var check wasn't accounting for IPv6 addresses. Consequence: The init container fails to succeed, and hence etcd never starts. Fix: Check for both ipv4 and ipv6 addresses (with square brackets) Result: The init container succeeds with env checks, and etcd container successfully starts.
Clone Of:
: 1822327 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:26:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 296 0 None closed Bug 1822326: Add extra checks for ipv6 addresses when checking the etcd env 2020-12-01 14:14:06 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:27:03 UTC

Description Suresh Kolichala 2020-04-08 18:21:39 UTC
Description of problem:

The fix for Bug 1817028 (https://bugzilla.redhat.com/show_bug.cgi?id=1817028) introduced a new init container to validate the etcd environment before firing up the etcd. However, the checks for ensuring the etcd environment rely on ipstring comparison which fails in the ipv6 environments. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a ipv6 cluster

Actual results:
The etcd members fails to start with the init container failing forever with an error similar to:
Expected node IP to be fd2e:6f44:5dd8:c956::15 got [fd2e:6f44:5dd8:c956::15]

Expected results:
etcd to come up normally, and the cluster to become available.

Additional info:

Comment 4 errata-xmlrpc 2020-07-13 17:26:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.