Bug 1822327 - The ip check in the etcd-ensure-env-vars init container doesn't work in the ipv6 environments
Summary: The ip check in the etcd-ensure-env-vars init container doesn't work in the i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1822326
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-08 18:22 UTC by Suresh Kolichala
Modified: 2020-05-04 11:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1822326
Environment:
Last Closed: 2020-05-04 11:48:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 306 0 None closed Bug 1817071: *: add an init container to stop the pod with bad revision 2021-02-04 13:46:43 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:49:02 UTC

Description Suresh Kolichala 2020-04-08 18:22:46 UTC
+++ This bug was initially created as a clone of Bug #1822326 +++

Description of problem:

The fix for Bug 1817028 (https://bugzilla.redhat.com/show_bug.cgi?id=1817028) introduced a new init container to validate the etcd environment before firing up the etcd. However, the checks for ensuring the etcd environment rely on ipstring comparison which fails in the ipv6 environments. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a ipv6 cluster

Actual results:
The etcd members fails to start with the init container failing forever with an error similar to:
Expected node IP to be fd2e:6f44:5dd8:c956::15 got [fd2e:6f44:5dd8:c956::15]

Expected results:
etcd to come up normally, and the cluster to become available.

Additional info:

Comment 1 ge liu 2020-04-24 03:22:17 UTC
Tried etcd on ipv6 virt cluster with 4.4 2 weeks ago,it works well, and we have not ipv6 env to double it now, so close this bug.

Comment 4 errata-xmlrpc 2020-05-04 11:48:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.